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CHAPTER 1. INTRODUCTION

Red Hat Enterprise Linux OpenStack Platform (RHEL OpenStack Platform) provides the
foundation to build a private or public Infrastructure-as-a-Service (IaaS) cloud on top of Red
Hat Enterprise Linux. It offers a massively scalable, fault-tolerant platform for the
development of cloud-enabled workloads.

This guide provides cloud-management procedures for the following OpenStack services:
Block Storage, Compute, Dashboard, Identity, Image, Object Storage, OpenStack
Networking, Orchestration, and Telemetry.

Procedures for both administrators and project users (end users) are provided;
administrator-only procedures are marked as such.

You can manage the cloud using either the OpenStack dashboard or the command-line
clients. Most procedures can be carried out using either method; some of the more advanced
procedures can only be executed on the command line. This guide provides procedures for
the dashboard where possible.

Note

For the complete suite of documentation for RHEL OpenStack Platform, see
https://access.redhat.com/documentation/en-
US/Red_Hat_Enterprise_Linux_OpenStack_Platform/

1.1. OPENSTACK DASHBOARD

The OpenStack dashboard is a web-based graphical user interface for managing
OpenStack services.

To access the browser dashboard, the dashboard service must be installed, and you must
know the dashboard host name (or IP) and login password. The dashboard URL will be:

http://HOSTNAME/dashboard/

Figure 1.1. Log In  Screen
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1.2. COMMAND-LINE CLIENTS

Each RHEL OpenStack Platform component typically has its own management client. For
example, the Compute service has the nova client. For a complete listing of client commands
and parameters, see the "Command-Line Interface Reference" in
https://access.redhat.com/documentation/en-
US/Red_Hat_Enterprise_Linux_OpenStack_Platform/

To use a command-line client, the client must be installed and you must first load the
environment variables used for authenticating with the Identity service. You can do this by
creating an RC (run control) environment file, and placing it in a secure location to run as
needed.

Run the file using:

$ source RC_FileName

Example 1.1. 

$ source ~/keystonerc_admin
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Note

By default, the Packstack utility creates the admin and demo  users, and their 
keystone_admin and keystone_demo  RC files.

1.2.1. Automat ically Create an RC File

Using the dashboard, you can automatically generate and download an RC file for the
current project user, which enables the use of the OpenStack command-line clients (see
Section 1.2, “Command-line Clients” ). The file's environment variables map to the project
and the current project's user.

1. In the dashboard, select the Project tab, and click Compute > Access & 
Security.

2. Select the API Access tab, which lists all services that are visible to the project's
logged-in user.

3. Click Download OpenStack RC file to generate the file. The file name maps to
the current user. For example, if you are an 'admin' user, an admin-openrc.sh file
is generated and downloaded through the browser.

1.2.2. Manually Create an RC File

If you create an RC file manually, you must set the following environment variables:

OS_USERNAME=userName

OS_TENANT_NAME=tenantName

OS_PASSWORD=userPassword

OS_AUTH_URL=http://IP:35357/v2.0/

PS1='[\u@\h \W(keystone_userName)]\$ '

Example 1.2. 

The following example file sets the necessary variables for the admin user:

export OS_USERNAME=admin
export OS_TENANT_NAME=admin
export OS_PASSWORD=secretPass
export OS_AUTH_URL=http://192.0.2.24:35357/v2.0/               
export PS1='[\u@\h \W(keystone_admin)]\$ '
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CHAPTER 2. PROJECTS AND USERS

As a cloud administrator, you can manage both projects and users. Projects are
organizational units in the cloud to which you can assign users. Projects are also known as
tenants or accounts. You can manage projects and users independently from each other.
Users can be members of one or more projects.

During cloud setup, the operator defines at least one project, user, and role. The operator
links the role to the user and the user to the project. Roles define the actions that users can
perform. As a cloud administrator, you can create additional projects and users as needed.
Additionally, you can add, update, and delete projects and users, assign users to one or
more projects, and change or remove these assignments. To enable or temporarily disable a
project or user, update that project or user.

After you create a user account, you must assign the account to a primary project.
Optionally, you can assign the account to additional projects. Before you can delete a user
account, you must remove the user account from its primary project.

2.1. MANAGE PROJECTS

2.1.1. Create a Project

1. As an admin user in the dashboard, select Identity > Projects.

2. Click Create Project.

3. On the Project Information tab, enter a name and description for the project
(the Enabled  check box is selected by default).

4. On the Project Members tab, add members to the project from the All Users list.

5. On the Quotas tab, specify resource limits for the project.

6. Click Create Project.

2.1.2. Update a Project

You can update a project to change its name or description, enable or temporarily disable it,
or update its members.

1. As an admin user in the dashboard, select Identity > Projects.

2. In the project's Actions column, click the arrow, and click Edit Project.

3. In the Edit Project window, you can update a project to change its name or
description, and enable or temporarily disable the project.
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4. On the Project Members tab, add members to the project, or remove them as
needed.

5. Click Save.

Note

The Enabled  check box is selected by default. To temporarily disable the project,
clear the Enabled  check box. To enable a disabled project, select the Enabled
check box.

2.1.3. Delete a Project

1. As an admin user in the dashboard, select Identity > Projects.

2. Select the project to delete.

3. Click Delete Projects.

4. Click Delete Projects again.

Note

You cannot undo the delete action.

2.1.4 . Update Project  Quotas

Quotas are maximum limits that can be set per project, so that the project's resources are not
exhausted.

1. As an admin user in the dashboard, select Identity > Projects.

2. In the project's Actions column, click the arrow, and click Modify Quotas.

3. In the Quota tab, modify project quotas as needed.

4. Click Save.

2.1.5. Manage Project  Security

Security groups are sets of IP filter rules that can be assigned to project instances, and
which define networking access to the instance. Security groups are project specific; project
members can edit the default rules for their security group and add new rule sets.
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All projects have a default security group that is applied to any instance that has no other
defined security group. Unless you change the default values, this security group denies all
incoming traffic and allows only outgoing traffic to your instance.

2.1 .5 .1 . Creat e a Securit y Gro up

1. In the dashboard, select Project > Compute > Access & Security.

2. On the Security Groups tab, click Create Security Group.

3. Provide a name and description for the group, and click Create Security Group.

2.1 .5 .2 . Add a Securit y Gro up Rule

By default, rules for a new group only provide outgoing access. You must add new rules to
provide additional access.

1. In the dashboard, select Project > Compute > Access & Security.

2. On the Security Groups tab, click Manage Rules for the security group.

3. Click Add Rule to add a new rule.

4. Specify the rule values, and click Add .

Table 2.1. Required Rule Fields

Field Descript ion

Rule

Rule typ e. If yo u sp ecify a rule temp late (fo r examp le, 'SSH'), its  field s are
auto matically fi l led  in:

TCP: Typ ically used  to  exchang e d ata b etween systems, and  fo r end -
user co mmunicatio n.

UDP: Typ ically used  to  exchang e d ata b etween systems, p articularly at
the ap p licatio n level.

ICMP: Typ ically used  b y netwo rk d evices, such as ro uters, to  send
erro r o r mo nito ring  messag es.

Directio
n

Ing ress (inb o und ), o r Eg ress (o utb o und )
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Op en
Po rt Fo r TCP o r UDP rules, the Port o r Port Range to  o p en fo r the rule

(s ing le p o rt o r rang e o f p o rts):

Fo r a rang e o f p o rts, enter p o rt values in the From Port and  To 
Port field s.

Fo r a s ing le p o rt, enter the p o rt value in the Port field .

Typ e The typ e fo r ICMP rules; must b e in the rang e ' -1:255' .

Co d e The co d e fo r ICMP rules; must b e in the rang e ' -1:255' .

Remo te The traffic  so urce fo r this  rule:

CIDR (Classless Inter-Do main Ro uting ): IP ad d ress b lo ck, which l imits
access to  IPs within the b lo ck. Enter the CIDR in the So urce field .

Security Gro up : So urce g ro up  that enab les any instance in the g ro up
to  access any o ther g ro up  instance.

Field Descript ion

2.1 .5 .3. Delet e  a Securit y Gro up Rule

1. In the dashboard, select Project > Compute > Access & Security.

2. On the Security Groups tab, click Manage Rules for the security group.

3. Select the security group rule, and click Delete Rule.

4. Click Delete Rule.

Note

You cannot undo the delete action.

2.1 .5 .4 . Delet e  a Securit y Gro up

1. In the dashboard, select Project > Compute > Access & Security.

2. On the Security Groups tab, select the group, and click Delete Security 
Groups.

3. Click Delete Security Groups.
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Note

You cannot undo the delete action.

2.2. MANAGE USERS

2.2.1. Create a User

1. As an admin user in the dashboard, select Identity > Users.

2. Click Create User.

3. Enter a user name, email, and preliminary password for the user.

4. Select a project from the Primary Project list.

5. Select a role for the user from the Role list (the default role is _member_).

6. Click Create User.

2.2.2. Enable or Disable a User

You can disable or enable only one user at a time.

1. As an admin user in the dashboard, select Identity > Users.

2. In the Actions column, click the arrow, and select Enable User or Disable 
User. In the Enabled  column, the value then updates to either True or False.

2.2.3. Delete a User

1. As an admin user in the dashboard, select Identity > Users.

2. Select the users that to delete.

3. Click Delete Users.

4. Click Delete Users.

Note

You cannot undo the delete action.
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2.2.4 . Manage Roles

2.2 .4 .1 . View Ro les

To list the available roles:

$ keystone role-list
+----------------------------------+---------------+
|                id                |      name     |
+----------------------------------+---------------+
| 71ccc37d41c8491c975ae72676db687f |     Member    |
| 149f50a1fe684bfa88dae76a48d26ef7 | ResellerAdmin |
| 9fe2ff9ee4384b1894a90878d3e92bab |    _member_   |
| 6ecf391421604da985db2f141e46a7c8 |     admin     |
+----------------------------------+---------------+

To get details for a specified role:

$ keystone role-get ROLE

Example 2.1. 

$ keystone role-get admin
+----------+----------------------------------+
| Property |              Value               |
+----------+----------------------------------+
|    id    | 6ecf391421604da985db2f141e46a7c8 |
|   name   |             admin                |
+----------+----------------------------------+

2.2 .4 .2 . Creat e and Assign a Ro le

Users can be members of multiple projects. To assign users to multiple projects, create a role
and assign that role to a user-project pair.

Note

Either the name or ID can be used to specify users, roles, or projects.

1. Create the new-role role:

$ keystone role-create --name ROLE_NAME

Example 2.2. 
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$ keystone role-create --name new-role
+----------+----------------------------------+
| Property |              Value               |
+----------+----------------------------------+
|    id    | 61013e7aa4ba4e00a0a1ab4b14bc6b2a |
|   name   |             new-role             |
+----------+----------------------------------+

2. To assign a user to a project, you must assign the role to a user-project pair. To do
this, you need the user, role, and project names or IDs.

a. List users:

$ keystone user-list

b. List roles:

$ keystone role-list

c. List projects:

$ keystone tenant-list

3. Assign a role to a user-project pair.

$ keystone user-role-add --user USER_NAME --role ROLE_NAME --
tenant TENANT_NAME

Example 2.3. 

In this example, you assign the new-role role to the demo -demo  pair:

$ keystone user-role-add --user demo --role new-role --
tenant demo

4. Verify the role assignment for the user demo :

$ keystone user-role-list --user USER_NAME --tenant 
TENANT_NAME

Example 2.4 . 

$ keystone user-role-list --user demo --tenant demo
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2.2 .4 .3. Delet e  a Ro le

1. Remove a role from a user-project pair:

$ keystone user-role-remove --user USER_NAME --role ROLE --
tenant TENANT_NAME

2. Verify the role removal:

$ keystone user-role-list --user USER_NAME --tenant 
TENANT_NAME

If the role was removed, the command output omits the removed role.

2.2.5. View Compute Quotas for a Project  User

To list the currently set quota values for a project user (tenant user), run:

$ nova quota-show --user USER --tenant TENANT

Example 2.5. 

$ nova quota-show --user demoUser --tenant demo
+-----------------------------+-------+
| Quota                       | Limit |
+-----------------------------+-------+
| instances                   | 10    |
| cores                       | 20    |
| ram                         | 51200 |
| floating_ips                | 5     |
| fixed_ips                   | -1    |
| metadata_items              | 128   |
| injected_files              | 5     |
| injected_file_content_bytes | 10240 |
| injected_file_path_bytes    | 255   |
| key_pairs                   | 100   |
| security_groups             | 10    |
| security_group_rules        | 20    |
| server_groups               | 10    |
| server_group_members        | 10    |      
+-----------------------------+-------+

2.2.6. Update Compute Quotas for a Project  User

Procedure 2.1. Update Compute Quotas for User
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To update a particular quota value, run:

$ nova quota-update --user USER --QUOTA_NAME QUOTA_VALUE TENANT

Example 2.6 . 

$ nova quota-update --user demoUser --floating-ips 10 demo
$ nova quota-show --user demoUser --tenant demo
+-----------------------------+-------+
| Quota                       | Limit |
+-----------------------------+-------+
| instances                   | 10    |
| cores                       | 20    |
| ram                         | 51200 |
| floating_ips                | 10    |
| ...                         |       |
+-----------------------------+-------+

Note

To view a list of options for the quota-update command, run:

$ nova help quota-update

2.2.7. Configure Role Access Cont rol

A user can have different roles in different tenants. A user can also have multiple roles in the
same tenant.

The /etc/[SERVICE_CODENAME]/policy.json file controls the tasks that users can
perform for a given service. For example:

/etc/nova/policy.json specifies the access policy for the Compute service.

/etc/glance/policy.json specifies the access policy for the Image Service

/etc/keystone/policy.json specifies the access policy for the Identity Service.

The default policy.json files for the Compute, Identity, and Image services recognize only
the admin role; all operations that do not require the admin role are accessible by any user
that has any role in a tenant.

For example, if you wish to restrict users from performing operations in the Compute service,
you must create a role in the Identity service, give users that role, and then modify 
/etc/nova/policy.json so that the role is required for Compute operations.
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Example 2.7. 

The following line in /etc/nova/policy.json specifies that there are no restrictions
on which users can create volumes; if the user has any role in a tenant, they can create
volumes in that tenant.

"volume:create": [],

Example 2.8. 

To restrict creation of volumes to users who had the compute-user role in a particular
tenant, you would add "role:compute-user"  to the Compute policy:

"volume:create": ["role:compute-user"],

Example 2.9 . 

To restrict all Compute service requests to require this role, values in the file might look
like the following (not a complete example):

{"admin_or_owner": [["role:admin"], ["project_id:%
(project_id)s"]],
"default": [["rule:admin_or_owner"]],
"compute:create": ["role:compute-user"],
"compute:create:attach_network": ["role:compute-user"],
"compute:create:attach_volume": ["role:compute-user"],
"compute:get_all": ["role:compute-user"],
"compute:unlock_override": ["rule:admin_api"],
"admin_api": [["role:admin"]],
"compute_extension:accounts": [["rule:admin_api"]],
"compute_extension:admin_actions": [["rule:admin_api"]],
"compute_extension:admin_actions:pause": 
[["rule:admin_or_owner"]],
"compute_extension:admin_actions:unpause": 
[["rule:admin_or_owner"]],
"compute_extension:admin_actions:suspend": 
[["rule:admin_or_owner"]],
"compute_extension:admin_actions:resume": 
[["rule:admin_or_owner"]],
"compute_extension:admin_actions:lock": [["rule:admin_or_owner"]],
"compute_extension:admin_actions:unlock": 
[["rule:admin_or_owner"]],
"compute_extension:admin_actions:resetNetwork": 
[["rule:admin_api"]],
"compute_extension:admin_actions:injectNetworkInfo": 
[["rule:admin_api"]],
"compute_extension:admin_actions:createBackup": 
[["rule:admin_or_owner"]],
"compute_extension:admin_actions:migrateLive": 
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[["rule:admin_api"]],
"compute_extension:admin_actions:migrate": [["rule:admin_api"]],
"compute_extension:aggregates": [["rule:admin_api"]],
"compute_extension:certificates": ["role:compute-user"],
"compute_extension:cloudpipe": [["rule:admin_api"]],
"compute_extension:console_output": ["role:compute-user"],
"compute_extension:consoles": ["role:compute-user"],
"compute_extension:createserverext": ["role:compute-user"],
"compute_extension:deferred_delete": ["role:compute-user"],
"compute_extension:disk_config": ["role:compute-user"],
"compute_extension:evacuate": [["rule:admin_api"]],
"compute_extension:extended_server_attributes": 
[["rule:admin_api"]],
 ...
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CHAPTER 3. VIRTUAL MACHINE INSTANCES

The RHEL OpenStack Platform allows you to easily manage virtual machine instances in the
cloud. OpenStack Compute is the central component that creates, schedules, and manages
instances, and exposes this functionality to other OpenStack components.

Note

The term ' instance' is used by OpenStack to mean a virtual machine instance.

3.1. MANAGE INSTANCES

3.1.1. Create an Instance

Prerequisites: Ensure that a network, key pair, and a boot source are available:

1. In the dashboard, select Project.

2. Select Network > Networks, and ensure there is a private network to which you
can attach the new instance (to create a network, see Section 5.1.1, “Add a Network” ).

3. Select Compute > Access & Security > Key Pairs, and ensure there is a
key pair (to create a key pair, see Section 3.2.1, “Manage Key Pairs” ).

4. Ensure that you have either an image or a volume that can be used as a boot source:

To view boot-source images, select the Images tab (to create an image, see
Section 4.1.1, “Create an Image” ).

To view boot-source volumes, select the Volumes tab (to create a volume, see
Section 4.2.1.1, “Create a Volume” ).

Procedure 3.1. Create an Instance

1. In the dashboard, select Project > Compute > Instances.

2. Click Launch Instance.

3. Fill out instance fields (those marked with '*'  are required), and click Launch when
finished.

T ab Field Not es
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Details Availab il i ty Zo ne Zo nes are lo g ical g ro up ing s o f c lo ud
reso urces in which yo ur instance can b e p laced .
If yo u are unsure, use the d efault zo ne (fo r mo re
info rmatio n, see sectio n Sectio n 3.4, “ Manag e
Ho st Ag g reg ates” ).

Instance Name The name must b e uniq ue within the p ro ject.

Flavo r The flavo r d etermines what reso urces the
instance is  g iven (fo r examp le, memo ry). Fo r
d efault flavo r allo catio ns and  info rmatio n o n
creating  new flavo rs, see Sectio n 3.3, “ Manag e
Flavo rs” .

Instance Bo o t
So urce Dep end ing  o n the item selected , new field s are

d isp layed  allo wing  yo u to  select the so urce:

Imag e so urces must b e co mp atib le with
Op enStack (see Sectio n 4.1, “ Manag e
Imag es” ).

If a vo lume o r vo lume so urce is  selected , the
so urce must b e fo rmatted  using  an imag e
(see Sectio n 4.2, “ Manag e Vo lumes” ).

Access and
Security

Key Pair The sp ecified  key p air is  injected  into  the
instance and  is  used  to  remo tely access the
instance using  SSH (if neither a d irect lo g in
info rmatio n o r a static  key p air is  p ro vid ed ).
Usually o ne key p air p er p ro ject is  created .

Security Gro up s Security g ro up s co ntain firewall rules which fi l ter
the typ e and  d irectio n o f the instance's netwo rk
traffic  (fo r mo re info rmatio n o n co nfig uring
g ro up s, see Sectio n 2.1.5, “ Manag e Pro ject
Security” ).

Netwo rking Selected  Netwo rks Yo u must select at least o ne netwo rk. Instances
are typ ically assig ned  to  a p rivate netwo rk, and
then later g iven a flo ating  IP ad d ress to  enab le
external access.

T ab Field Not es
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Po st-
Creatio n

Custo mizatio n
Scrip t So urce

Yo u can p ro vid e either a set o f co mmand s o r a
scrip t fi le, which wil l run after the instance is
b o o ted  (fo r examp le, to  set the instance
ho stname o r a user p asswo rd ). If 'Direct Inp ut'
is  selected , write yo ur co mmand s in the Script 
Data field ; o therwise, sp ecify yo ur scrip t fi le.
Not e: Any scrip t that s tarts  with '#c lo ud -co nfig '
is  interp reted  as using  the c lo ud -co nfig  syntax
(fo r info rmatio n o n the syntax, see
http ://c lo ud init.read thed o cs.o rg /en/latest/to p ics
/examp les.html).

Ad vanced
Op tio ns

Disk Partitio n By d efault, the instance is  b uilt as a s ing le
p artitio n and  d ynamically res ized  as need ed .
Ho wever, yo u can cho o se to  manually co nfig ure
the p artitio ns yo urself.

Co nfig uratio n
Drive

If selected , Op enStack writes metad ata to  a
read -o nly co nfig uratio n d rive that is  attached  to
the instance when it b o o ts (instead  o f to
Co mp ute's metad ata service). After the instance
has b o o ted , yo u can mo unt this  d rive to  view its
co ntents (enab les yo u to  p ro vid e fi les to  the
instance).

T ab Field Not es

3.1.2. Update an Instance (Act ions menu)

You can update an instance by selecting Project > Compute > Instance, and
selecting an action for that instance in the Actions column. Actions allow you to manipulate
the instance in a number of ways:

Act ion Descript ion

Create Snap sho t Snap sho ts p reserve the d isk state o f a running  instance. Yo u can
create a snap sho t to  mig rate the instance, as well as to  p reserve
b ackup  co p ies.

Asso ciate/Disasso ci
ate Flo ating  IP

Yo u must asso ciate an instance with a flo ating  IP (external) ad d ress
b efo re it can co mmunicate with external netwo rks, o r b e reached  b y
external users. Because there are a l imited  numb er o f external
ad d resses in yo ur external sub nets, it is  reco mmend ed  that yo u
d isasso ciate any unused  ad d resses.

Ed it Instance Up d ate the instance's name and  asso ciated  security g ro up s.

Ed it Security Gro up s Ad d  and  remo ve security g ro up s to  o r fro m this instance using  the
lis t o f availab le security g ro up s (fo r mo re info rmatio n o n co nfig uring
g ro up s, see Sectio n 2.1.5, “ Manag e Pro ject Security” ).
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Co nso le View the instance's co nso le in the b ro wser (allo ws easy access to  the
instance).

View Lo g View the mo st recent sectio n o f the instance's co nso le lo g . Once
o p ened , yo u can view the full lo g  b y c licking  View Full Log .

Pause/Resume
Instance

Immed iately p ause the instance (yo u are no t asked  fo r co nfirmatio n);
the state o f the instance is  sto red  in memo ry (RAM).

Susp end /Resume
Instance

Immed iately susp end  the instance (yo u are no t asked  fo r
co nfirmatio n); l ike hyb ernatio n, the state o f the instance is  kep t o n
d isk.

Resize Instance Bring  up  the Resize Instance wind o w (see Sectio n 3.1.3, “ Resize an
instance” ).

So ft Reb o o t Gracefully s to p  and  restart the instance. A so ft reb o o t attemp ts to
g racefully shut d o wn all p ro cesses b efo re restarting  the instance.

Hard  Reb o o t Sto p  and  restart the instance. A hard  reb o o t effectively just shuts
d o wn the instance's 'p o wer'  and  then turns it b ack o n.

Shut O ff Instance Gracefully s to p  the instance.

Reb uild  Instance Use new imag e and  d isk-p artitio n o p tio ns to  reb uild  the imag e (shut
d o wn, re-imag e, and  re-b o o t the instance). If enco untering  o p erating
system issues, this  o p tio n is  easier to  try than terminating  the
instance and  starting  o ver.

Terminate Instance Permanently d estro y the instance (yo u are asked  fo r co nfirmatio n).

Act ion Descript ion

For example, you can create and allocate an external address by using the 'Associate
Floating IP' action.

Procedure 3.2. Update Example -  Assign a Float ing IP

1. In the dashboard, select Project > Compute > Instances.

2. Select the Associate Floating IP  action for the instance.

Note

A floating IP address can only be selected from an already created floating
IP pool (see Section 5.2.1, “Create Floating IP Pools” ).

3. Click '+' and select Allocate IP > Associate .
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Note

If you do not know the name of the instance, just its IP address (and you do not
want to flip through the details of all your instances), you can run the following on
the command line:

$ nova list --ip IPAddress

Where IPAddress is the IP address you are looking up.

$ nova list --ip 192.0.2.0

3.1.3. Resize an instance

To resize an instance (memory or CPU count), you must select a new flavor for the instance
that has the right capacity. If you are increasing the size, remember to first ensure that the
host has enough space.

1. If you are resizing an instance in a distributed deployment, you must ensure
communication between hosts. Set up each host with SSH key authentication so that
Compute can use SSH to move disks to other hosts (for example, compute nodes can
share the same SSH key). For more information about setting up SSH key
authentication, see Section 3.1.4, “Configure SSH Tunneling between Nodes” .

2. Enable resizing on the original host by setting the following parameter in the 
/etc/nova/nova.conf file:

3. In the dashboard, select Project > Compute > Instances.

4. Click the instance's Actions arrow, and select Resize Instance.

5. Select a new flavor in the New Flavor field.

6. If you want to manually partition the instance when it launches (results in a faster
build time):

a. Select Advanced Options.

b. In the Disk Partition field, select 'Manual'.

7. Click Resize.

3.1.4 . Configure SSH T unneling between Nodes

[DEFAULT] allow_resize_to_same_host = True
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To migrate instances between nodes using SSH tunneling or to resize instance in a
distributed environment, each node must be set up with SSH key authentication so that the
Compute service can use SSH to move disks to other nodes. For example, compute nodes
could use the same SSH key to ensure communication.

Note

If the Compute service cannot migrate the instance to a different node, it will attempt
to migrate the instance back to its original host. To avoid migration failure in this
case, ensure that 'allow_migrate_to_same_host=True' is set in the 
/etc/nova/nova.conf file.

To share a key pair between compute nodes:

1. As root on both nodes, make nova a login user:

# usermod -s /bin/bash nova

2. On the first compute node, generate a key pair for the nova user:

# su nova
# ssh-keygen
# echo 'StrictHostKeyChecking no' >> /var/lib/nova/.ssh/config
# cat /var/lib/nova/.ssh/id_rsa.pub >> 
/var/lib/nova/.ssh/authorized_keys

The key pair, id_rsa and id_rsa.pub, is generated in /var/lib/nova/.ssh.

3. As root, copy the created key pair to the second compute node:

# scp /var/lib/nova/.ssh/id_rsa root@computeNodeAddress:~/
# scp /var/lib/nova/.ssh/id_rsa.pub root@computeNodeAddress:~/

4. As root on the second compute node, change the copied key pair's permissions back
to 'nova', and then add the key pair into SSH:

# chown nova:nova id_rsa
# chown nova:nova id_rsa.pub
# su nova
# mkdir -p /var/lib/nova/.ssh

Warning

Red Hat does not recommend any particular libvirt security strategy; SSH-
tunneling steps are provided for user reference only. Only users with root access
can set up SSH tunneling.
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# cp id_rsa /var/lib/nova/.ssh/
# cat id_rsa.pub >> /var/lib/nova/.ssh/authorized_keys
# echo 'StrictHostKeyChecking no' >> /var/lib/nova/.ssh/config

5. Ensure that the nova user can now log into each node without using a password:

# su nova 
# ssh nova@computeNodeAddress

6. As root on both nodes, restart both libvirt and the Compute services:

# systemctl restart libvirtd.service
# systemctl restart openstack-nova-compute.service

3.1.5. Connect  to an Instance

3.1 .5 .1 . Access using t he Dashbo ard Co nso le

The console allows you a way to directly access your instance within the dashboard.

1. In the dashboard, select Compute > Instances.

2. Click the instance's More button and select Console.

Figure 3.1. Console Access
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3. Log in using the image's user name and password (for example, a CirrOS image
uses 'cirros'/'cubswin:)').

Note

Red Hat Enterprise Linux guest images typically do not allow direct console
access; you must SSH into the instance (see Section 3.1.5.4, “SSH into an
Instance” ).

3.1 .5 .2 . Direct ly Co nnect  t o  a VNC Co nso le

You can directly access an instance's VNC console using a URL returned by nova get-
vnc-console command.

Browser

To obtain a browser URL, use:

$ nova get-vnc-console INSTANCE_ID novnc

Java Client

To obtain a Java-client URL, use:

$ nova get-vnc-console INSTANCE_ID xvpvnc
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Note

nova-xvpvncviewer provides a simple example of a Java client. To
download the client, use:

# git clone https://github.com/cloudbuilders/nova-
xvpvncviewer
# cd nova-xvpvncviewer/viewer
# make

Run the viewer with the instance's Java-client URL:

# java -jar VncViewer.jar URL

This tool is provided only for customer convenience, and is not officially
supported by Red Hat.

3.1 .5 .3. Direct ly Co nnect  t o  a Serial Co nso le

You can directly access an instance's serial port using a websocket client. Serial
connections are typically used as a debugging tool (for example, instances can be
accessed even if the network configuration fails). To obtain a serial URL for a running
instance, use:

$ nova get-serial-console INSTANCE_ID

Note

novaconsole provides a simple example of a websocket client. To download the
client, use:

# git clone https://github.com/larsks/novaconsole/
# cd novaconsole

Run the client with the instance's serial URL:

# python console-client-poll.py URL

This tool is provided only for customer convenience, and is not officially supported
by Red Hat.

However, depending on your installation, the administrator may need to first set up the 
nova-serialproxy service. The proxy service is a websocket proxy that allows
connections to OpenStack Compute serial ports.
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Procedure 3.3. Install and Conf igure nova-serialproxy

1. Install the nova-serialproxy service:

# yum install openstack-nova-serialproxy

2. Update the serial_console section in /etc/nova/nova.conf:

a. Enable the nova-serialproxy service:

$ openstack-config --set /etc/nova/nova.conf 
serial_console enabled true

b. Specify the string used to generate URLS provided by the nova get-
serial-console command.

$ openstack-config --set /etc/nova/nova.conf 
serial_console base_url ws://PUBLIC_IP:6083/

Where PUBLIC_IP is the public IP address of the host running the nova-
serialproxy service.

c. Specify the IP address on which the instance serial console should listen
(string).

$ openstack-config --set /etc/nova/nova.conf 
serial_console listen 0.0.0.0

d. Specify the address to which proxy clients should connect (string).

$ openstack-config --set /etc/nova/nova.conf 
serial_console proxyclient_address ws://HOST_IP:6083/

Where HOST_IP is the IP address of your Compute host.

Example 3.1. Enabled nova-serialproxy

3. Restart Compute services:

[serial_console]
enabled=true
base_url=ws://192.0.2.0:6083/
listen=0.0.0.0
proxyclient_address=192.0.2.3
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# openstack-service restart nova

4. Start the nova-serialproxy service:

# systemctl enable openstack-nova-serialproxy
# systemctl start openstack-nova-serialproxy

5. Restart any running instances, to ensure that they are now listening on the right
sockets.

6. Open the firewall for serial-console port connections. Serial ports are set using 
[serial_console] port_range in /etc/nova/nova.conf; by default, the
range is 10000:20000. Update iptables with:

# iptables -I INPUT 1 -p tcp --dport 10000:20000 -j ACCEPT

3.1 .5 .4 . SSH int o  an Inst ance

1. Ensure that the instance's security group has an SSH rule (see Section 2.1.5,
“Manage Project Security” ).

2. Ensure the instance has a floating IP address (external address) assigned to it (see
Section 3.2.2, “Create, Assign, and Release Floating IP Addresses” ).

3. Obtain the instance's key-pair certificate. The certificate is downloaded when the key
pair is created; if you did not create the key pair yourself, ask your administrator (see
Section 3.2.1, “Manage Key Pairs” ).

4. On your local machine, load the key-pair certificate into SSH. For example:

$ ssh-add ~/.ssh/os-key.pem

5. You can now SSH into the file with the user supplied by the image.

The following example command shows how to SSH into the Red Hat Enterprise
Linux guest image with the user 'cloud-user':

$ ssh cloud-user@192.0.2.24

Note

You can also use the certificate directly. For example:

$ ssh -i /myDir/os-key.pem cloud-user@192.0.2.24
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3.1.6. View Instance Usage

The following usage statistics are available:

Per Project

To view instance usage per project, select Project > Compute > Overview. A usage
summary is immediately displayed for all project instances.

You can also view statistics for a specific period of time by specifying the date range and
clicking Submit.

Per Hypervisor

If logged in as an administrator, you can also view information for all projects. Click 
Admin > System and select one of the tabs. For example, the Resource Usage tab
offers a way to view reports for a distinct time period. You might also click Hypervisors
to view your current vCPU, memory, or disk statistics.

Note

The 'vCPU Usage' value ('x of y') reflects the number of total vCPUs of all virtual
machines (x) and the total number of hypervisor cores (y).

3.1.7. Delete an Instance

1. In the dashboard, select Project > Compute > Instances, and select your
instance.

2. Click Terminate Instance.

Note

Deleting an instance does not delete its attached volumes; you must do this
separately (see Section 4.2.1.4, “Delete a Volume” ).

3.2. MANAGE INSTANCE SECURITY

You can manage access to an instance by assigning it the correct security group (set of
firewall rules) and key pair (enables SSH user access). Further, you can assign a floating IP
address to an instance to enable external network access. The sections below outline how to
create and manage key pairs and floating IP addresses. For information on managing
security groups, see Section 2.1.5, “Manage Project Security” .

3.2.1. Manage Key Pairs
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Key pairs provide SSH access to the instances. Each time a key pair is generated, its
certificate is downloaded to the local machine and can be distributed to users. Typically, one
key pair is created for each project (and used for multiple instances).

You can also import an existing key pair into OpenStack.

3.2 .1 .1 . Creat e a Key Pair

1. In the dashboard, select Project > Compute > Access & Security.

2. On the Key Pairs tab, click Create Key Pair.

3. Specify a name in the Key Pair Name field, and click Create Key Pair.

When the key pair is created, a key pair file is automatically downloaded through the
browser. Save this file for later connections from external machines. For command-
line SSH connections, you can load this file into SSH by executing:

# ssh-add ~/.ssh/OS-Key.pem

3.2 .1 .2 . Impo rt  a Key Pair

1. In the dashboard, select Project > Compute > Access & Security.

2. On the Key Pairs tab, click Import Key Pair.

3. Specify a name in the Key Pair Name field, and copy and paste the contents of
your public key into the Public Key field.

4. Click Import Key Pair.

3.2 .1 .3. Delet e  a Key Pair

1. In the dashboard, select Project > Compute > Access & Security.

2. On the Key Pairs tab, click the key's Delete Key Pair button.

3.2.2. Create, Assign, and Release Float ing IP Addresses

By default, an instance is given an internal IP address when it is first created. However, you
can enable access through the public network by creating and assigning a floating IP
address (external address). You can change an instance's associated IP address
regardless of the instance's state.
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Projects have a limited range of floating IP address that can be used (by default, the limit is
50), so you should release these addresses for reuse when they are no longer needed.
Floating IP addresses can only be allocated from an existing floating IP pool (see
Section 5.2.1, “Create Floating IP Pools” ).

Procedure 3.4 . Allocate a Float ing IP to  the Pro ject

1. In the dashboard, select Project > Compute > Access & Security.

2. On the Floating IPs tab, click Allocate IP to Project.

3. Select a network from which to allocate the IP address in the Pool  field.

4. Click Allocate IP .

Procedure 3.5. Assign a Float ing IP

1. In the dashboard, select Project > Compute > Access & Security.

2. On the Floating IPs tab, click the address' Associate button.

3. Select the address to be assigned in the IP address field.

Note

If no addresses are available, you can click the +  button to create a new
address.

4. Select the instance to be associated in the Port to be Associated  field. An
instance can only be associated with one floating IP address.

5. Click Associate.

Procedure 3.6 . Release a Float ing IP

1. In the dashboard, select Project > Compute > Access & Security.

2. On the Floating IPs tab, click the address' menu arrow (next to the 
Associate/Disassociate button.

3. Select Release Floating IP .

3.3. MANAGE FLAVORS
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Each created instance is given a flavor (resource template), which determines the instance's
size and capacity. Flavors can also specify secondary ephemeral storage, swap disk,
metadata to restrict usage, or special project access (none of the default flavors have these
additional attributes defined).

Table 3.1. Default  Flavors

Name vCPUs RAM Root  Disk Size

m1.tiny 1 512 MB 1 GB

m1.small 1 20 48  MB 20  GB

m1.med ium 2 40 9 6  MB 40  GB

m1.larg e 4 8 19 2 MB 8 0  GB

m1.xlarg e 8 16 38 4 MB 16 0  GB

The majority of end users will be able to use the default flavors. However, you might need to
create and manage specialized flavors. For example, you might:

Change default memory and capacity to suit the underlying hardware needs.

Add metadata to force a specific I/O rate for the instance or to match a host aggregate.

Note

Behavior set using image properties overrides behavior set using flavors (for more
information, see Section 4.1, “Manage Images” ).

3.3.1. Update Configurat ion Permissions

By default, only administrators can create flavors or view the complete flavor list (select 
Admin > System > Flavors). To allow all users to configure flavors, specify the
following in the /etc/nova/policy.json file (nova-api  server):

"compute_extension:flavormanage": "",

3.3.2. Create a Flavor

1. As an admin user in the dashboard, select Admin > System > Flavors.

2. Click Create Flavor, and specify the following fields:
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T ab Field Descript ion

Flavo r
Info rmati
o n

Name Uniq ue name.

ID Uniq ue ID. The d efault value, 'auto ' , g enerates a
UUID4 value, b ut yo u can also  manually sp ecify
an integ er o r UUID4 value.

VCPUs Numb er o f virtual CPUs.

RAM (MB) Memo ry (in meg ab ytes).

Ro o t Disk (GB) Ep hemeral d isk s ize (in g ig ab ytes); to  use the
native imag e s ize, sp ecify '0 ' . This d isk is  no t
used  if ' Instance Bo o t So urce=Bo o t fro m Vo lume' .

Ep ehemeral Disk
(GB)

Seco nd ary ep hemeral d isk s ize (in g ig ab ytes).

Swap  Disk (MB) Swap  d isk s ize (in meg ab ytes).

Flavo r
Access

Selected  Pro jects Pro jects which can use the flavo r. If no  p ro jects
are selected , all p ro jects have access
('Pub lic=Yes' ).

3. Click Create Flavor.

3.3.3. Update General At t ributes

1. As an admin user in the dashboard, select Admin > System > Flavors.

2. Click the flavor's Edit Flavor button.

3. Update the values, and click Save.

3.3.4 . Update Flavor Metadata

In addition to editing general attributes, you can add metadata to a flavor ('extra_specs'),
which can help fine-tune instance usage. For example, you might want to set the maximum-
allowed bandwidth or disk writes.

Pre-defined keys determine hardware support or quotas. Pre-defined keys are limited by
the hypervisor you are using (for libvirt, see Table 3.2, “Libvirt Metadata” ).
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Both pre-defined and user-defined keys can determine instance scheduling. For example,
you might specify 'SpecialComp=True'; any instance with this flavor can then only run in
a host aggregate with the same key-value combination in its metadata (see Section 3.4,
“Manage Host Aggregates” ).

3.3.4 .1 . View Met adat a

1. As an admin user in the dashboard, select Admin > System > Flavors.

2. Click the flavor's Metadata link ('Yes' or 'No'). All current values are listed on the
right-hand side under Existing Metadata.

3.3.4 .2 . Add Met adat a

You specify a flavor's metadata using a key/value pair.

1. As an admin user in the dashboard, select Admin > System > Flavors.

2. Click the flavor's Metadata link ('Yes' or 'No'). All current values are listed on the
right-hand side under Existing Metadata.

3. Under Available Metadata, click on the Other field, and specify the key you
want to add (see Table 3.2, “Libvirt Metadata”  ).

4. Click the +  button; you can now view the new key under Existing Metadata.

5. Fill in the key's value in its right-hand field.

Figure 3.2. Flavor Metadata

6. When finished with adding key-value pairs, click Save.

Table 3.2. Libvirt  Metadata
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Key Descript ion

hw:action

Actio n that co nfig ures sup p o rt l imits  p er instance. Valid
actio ns are:

cpu_max_sockets - Maximum sup p o rted  CPU
so ckets.

cpu_max_cores - Maximum sup p o rted  CPU co res.

cpu_max_threads - Maximum sup p o rted  CPU
thread s.

cpu_sockets - Preferred  numb er o f CPU so ckets.

cpu_cores - Preferred  numb er o f CPU co res.

cpu_threads - Preferred  numb er o f CPU thread s.

serial_port_count - Maximum serial p o rts p er
instance.

Examp le: 'hw:cp u_max_so ckets=2'
hw:NUMA_def

Definitio n o f NUMA to p o lo g y fo r the instance. Fo r flavo rs
who se RAM and  vCPU allo catio ns are larg er than the s ize
o f NUMA no d es in the co mp ute ho sts, d efining  NUMA
to p o lo g y enab les ho sts to  b etter uti l ize NUMA and
imp ro ve p erfo rmance o f the g uest OS.

NUMA d efinitio ns d efined  thro ug h the flavo r o verrid e
imag e d efinitio ns. Valid  d efinitio ns are:

numa_nodes - Numb er o f NUMA no d es to  exp o se to
the instance. Sp ecify '1'  to  ensure imag e NUMA setting s
are o verrid d en.

numa_mempolicy - Memo ry allo catio n p o licy. Valid
p o lic ies are:

stric t - Mand ato ry fo r the instance's RAM allo catio ns
to  co me fro m the NUMA no d es to  which it is  b o und
(d efault if numa_nodes is  sp ecified ).

p referred  - The kernel can fall b ack to  using  an
alternative no d e. Useful when the numa_nodes is
set to  '1' .

numa_cpus.0  - Map p ing  o f vCPUs N-M to  NUMA
no d e 0  (co mma-sep arated  l is t).
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numa_cpus.1 - Map p ing  o f vCPUs N-M to  NUMA
no d e 1 (co mma-sep arated  l is t).

numa_mem.0  - Map p ing  N GB o f RAM to  NUMA no d e
0 .

numa_mem.1 - Map p ing  N GB o f RAM to  NUMA no d e
1.

numa_cpu.N and  numa_mem.N are o nly valid  if 
numa_nodes is  set. Ad d itio nally, they are o nly
req uired  if the instance's NUMA no d es have an
asymetrical allo catio n o f CPUs and  RAM (imp o rtant fo r
so me NFV wo rklo ad s). No te: If the values o f numa_cpu
o r numa_mem.N sp ecify mo re than that availab le, an
excep tio n is  raised .

Examp le when the instance has 8  vCPUs and  4GB RAM:

hw:numa_no d es=2

hw:numa_cp us.0 =0 ,1,2,3,4,5

hw:numa_cp us.1=6 ,7

hw:numa_mem.0 =3

hw:numa_mem.1=1

The sched uler lo o ks fo r a ho st with 2 NUMA no d es with the
ab il ity to  run 6  CPUs +  3 GB o f RAM o n o ne no d e, and  2
CPUS +  1 GB o f RAM o n ano ther no d e. If a ho st has a
sing le NUMA no d e with cap ab il ity to  run 8  CPUs and  4 GB
o f RAM, it wil l  no t b e co nsid ered  a valid  match. The same
lo g ic is  ap p lied  in the sched uler reg ard less o f the 
numa_mempolicy setting .

hw:watchdog_action

An instance watchd o g  d evice can b e used  to  trig g er an
actio n if the instance so meho w fails  (o r hang s). Valid
actio ns are:

disabled  - The d evice is  no t attached  (d efault value).

pause - Pause the instance.

poweroff - Fo rcefully shut d o wn the instance.

reset - Fo rcefully reset the instance.

none - Enab le the watchd o g , b ut d o  no thing  if the
instance fails .

Examp le: 'hw:watchd o g _actio n=p o wero ff'

Key Descript ion
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hw_rng:action

A rand o m-numb er g enerato r d evice can b e ad d ed  to  an
instance using  its  imag e p ro p erties (see hw_rng_model
in the " Co mmand -Line Interface Reference"  in RHEL
Op enStack Platfo rm d o cumentatio n).

If the d evice has b een ad d ed , valid  actio ns are:

allowed  - If 'True' , the d evice is  enab led ; if 'False' ,
d isab led . By d efault, the d evice is  d isab led .

rate_bytes - Maximum numb er o f b ytes the instance's
kernel can read  fro m the ho st to  fi l l  i ts  entro p y p o o l
every rate_period  (integ er).

rate_period  - Duratio n o f the read  p erio d  in
seco nd s (integ er).

Examp le: 'hw_rng :allo wed =True' .

hw_video:ram_max_mb

Maximum p ermitted  RAM to  b e allo wed  fo r vid eo  d evices
(in MB).

Examp le: 'hw:ram_max_mb =6 4'

quota: option

Enfo rc ing  l imit fo r the instance. Valid  o p tio ns are:

cpu_period  - Time p erio d  fo r enfo rc ing  cp u_q uo ta
(in micro seco nd s). Within the sp ecified  cp u_p erio d ,
each vCPU canno t co nsume mo re than cp u_q uo ta o f
runtime. The value must b e in rang e [10 0 0 , 10 0 0 0 0 0 ];
'0 '  means 'no  value' .

cpu_quota - Maximum allo wed  b and wid th (in
micro seco nd s) fo r the vCPU in each cp u_p erio d . The
value must b e in rang e [10 0 0 , 18 446 7440 7370 9 551]. '0 '
means 'no  value' ; a neg ative value means that the vCPU
is no t co ntro lled . cpu_quota and  cpu_period  can
b e used  to  ensure that all vCPUs run at the same
sp eed .

cpu_shares - Share o f CPU time fo r the d o main. The
value o nly has meaning  when weig hted  ag ainst o ther
machine values in the same d o main. That is , an
instance with a flavo r with '20 0 '  wil l  g et twice as much
machine time as an instance with '10 0 ' .

Key Descript ion
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disk_read_bytes_sec - Maximum d isk read s in
b ytes p er seco nd .

disk_read_iops_sec - Maximum read  I/O
o p eratio ns p er seco nd .

disk_write_bytes_sec - Maximum d isk writes in
b ytes p er seco nd .

disk_write_iops_sec - Maximum write I/O
o p eratio ns p er seco nd .

disk_total_bytes_sec - Maximum to tal thro ug hp ut
limit in b ytes p er seco nd .

disk_total_iops_sec - Maximum to tal I/O
o p eratio ns p er seco nd .

vif_inbound_average - Desired  averag e o f
inco ming  traffic .

vif_inbound_burst - Maximum amo unt o f traffic
that can b e received  at vif_inbound_peak sp eed .

vif_inbound_peak - Maximum rate at which
inco ming  traffic  can b e received .

vif_outbound_average - Desired  averag e o f
o utg o ing  traffic .

vif_outbound_burst - Maximum amo unt o f traffic
that can b e sent at vif_outbound_peak sp eed .

vif_outbound_peak - Maximum rate at which
o utg o ing  traffic  can b e sent.

Examp le: 'q uo ta:vif_inb o und _averag e=10 240 '

Key Descript ion

3.4 . MANAGE HOST AGGREGATES

A single Compute deployment can be partitioned into logical groups for performance or
administrative purposes. OpenStack uses the following terms:

Host aggregates - A host aggregate creates logical units in a OpenStack deployment by
grouping together hosts. Aggregates are assigned Compute hosts and associated
metadata; a host can be in more than one host aggregate. Only administrators can see or
create host aggregates.

An aggregate's metadata is commonly used to provide information for use with the
Compute scheduler (for example, limiting specific flavors or images to a subset of hosts).
Metadata specified in a host aggregate will limit the use of that host to any instance that
has the same metadata specified in its flavor.
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Administrators can use host aggregates to handle load balancing, enforce physical
isolation (or redundancy), group servers with common attributes, or separate out classes
of hardware. When you create an aggregate, a zone name must be specified, and it is this
name which is presented to the end user.

Availability zones - An availability zone is the end-user view of a host aggregate. An end
user cannot view which hosts make up the zone, nor see the zone's metadata; the user
can only see the zone's name.

End users can be directed to use specific zones which have been configured with certain
capabilities or within certain areas.

3.4 .1. Enable Host  Aggregate Scheduling

By default, host-aggregate metadata is not used to filter instance usage; you must update
the Compute scheduler's configuration to enable metadata usage:

1. Edit the /etc/nova/nova.conf file (you must have either root or nova user
permissions).

2. Ensure that the scheduler_default_filters parameter contains:

'AggregateInstanceExtraSpecsFilter' for host aggregate metadata. For example:

'AvailabilityZoneFilter' for availability host specification when launching an
instance. For example:

3. Save the configuration file.

3.4 .2. View Availabilit y Zones or Host  Aggregates

As an admin user in the dashboard, select Admin > System > Host Aggregates. All
currently defined aggregates are listed in the Host Aggregates section; all zones are
in the Availability Zones section.

3.4 .3. Add a Host  Aggregate

scheduler_default_filters=AggregateInstanceExtraSpecsFilter,Re
tryFilter,RamFilter,ComputeFilter,ComputeCapabilitiesFilter,I
magePropertiesFilter,CoreFilter

scheduler_default_filters=AvailabilityZoneFilter,RetryFilter,R
amFilter,ComputeFilter,ComputeCapabilitiesFilter,ImagePropert
iesFilter,CoreFilter
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1. As an admin user in the dashboard, select Admin > System > Host 
Aggregates. All currently defined aggregates are listed in the Host Aggregates
section.

2. Click Create Host Aggregate.

3. Add a name for the aggregate in the Name field, and a name by which the end user
should see it in the Availability Zone field.

4. Click Manage Hosts within Aggregate.

5. Select a host for use by clicking its +  icon.

6. Click Create Host Aggregate.

3.4 .4 . Update a Host  Aggregate

1. As an admin user in the dashboard, select Admin > System > Host 
Aggregates. All currently defined aggregates are listed in the Host Aggregates
section.

2. To update the instance's:

Name or availability zone:

Click the aggregate's Edit Host Aggregate button.

Update the Name or Availability Zone field, and click Save.

Assigned hosts:

Click the aggregate's arrow icon under Actions.

Click Manage Hosts.

Change a host's assignment by clicking its +  or - icon.

When finished, click Save.

Metatdata:

Click the aggregate's arrow icon under Actions.

Click the Update Metadata button. All current values are listed on the
right-hand side under Existing Metadata.

CHAPT ER 3. VIRT UAL MACHINE INST ANCES

39



Under Available Metadata, click on the Other field, and specify the
key you want to add. Use predefined keys (see Table 3.3, “Host Aggregate
Metadata”  ) or add your own (which will only be valid if exactly the same
key is set in an instance's flavor).

Click the +  button; you can now view the new key under Existing 
Metadata.

Note: Remove a key by clicking its - icon.

Click Save.

Table 3.3. Host  Aggregate Metadata

Key Descript ion

cpu_allocation
_ratio

Sets allo catio n ratio  o f virtual CPU to  p hysical CPU.
Dep end s o n the AggregateCoreFilter fi l ter b eing
set fo r the Co mp ute sched uler.

disk_allocatio
n_ratio

Sets allo catio n ratio  o f Virtual d isk to  p hysical d isk.
Dep end s o n the AggregateDiskFilter fi l ter b eing
set fo r the Co mp ute sched uler.

filter_tenant_i
d

If sp ecified , the ag g reg ate o nly ho sts this  tenant (p ro ject).
Dep end s o n the 
AggregateMultiTenancyIsolation fi l ter b eing  set
fo r the Co mp ute sched uler.

ram_allocation
_ratio

Sets allo catio n ratio  o f virtual RAM to  p hysical RAM.
Dep end s o n the AggregateRamFilter fi l ter b eing  set
fo r the Co mp ute sched uler.

3.4 .5. Delete a Host  Aggregate

1. As an admin user in the dashboard, select Admin > System > Host 
Aggregates. All currently defined aggregates are listed in the Host Aggregates
section.

2. Remove all assigned hosts from the aggregate:

1. Click the aggregate's arrow icon under Actions.

2. Click Manage Hosts.

3. Remove all hosts by clicking their - icon.
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4. When finished, click Save.

3. Click the aggregate's arrow icon under Actions.

4. Click Delete Host Aggregate in this and the next dialog screen.

3.5. SCHEDULE HOSTS AND CELLS

The Compute scheduling service determines on which cell or host (or host aggregate), an
instance will be placed. As an administrator, you can influence where the scheduler will
place an instance. For example, you might want to limit scheduling to hosts in a certain
group or with the right RAM.

You can configure the following components:

Filters - Determine the initial set of hosts on which an instance might be placed (see
Section 3.5.1, “Configure Scheduling Filters” ).

Weights - When filtering is complete, the resulting set of hosts are prioritized using the
weighting system. The highest weight has the highest priority (see Section 3.5.2,
“Configure Scheduling Weights” ).

Scheduler service - There are a number of configuration options in the 
/etc/nova/nova.conf file (on the scheduler host), which determine how the scheduler
executes its tasks, and handles weights and filters. There is both a host and a cell
scheduler. For a list of these options, refer to the "Configuration Reference" (RHEL
OpenStack Platform Documentation).

In the following diagram, both host 1 and 3 are eligible after filtering. Host 1 has the highest
weight and therefore has the highest priority for scheduling.

Figure 3.3. Scheduling Hosts

3.5.1. Configure Scheduling Filters
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You define which filters you would like the scheduler to use in the 
scheduler_default_filters option (/etc/nova/nova.conf file; you must have
either root or nova user permissions). Filters can be added or removed.

By default, the following filters are configured to run in the scheduler:

Some filters use information in parameters passed to the instance in:

The nova boot command, see the "Command-Line Interface Reference" in
https://access.redhat.com/documentation/en-
US/Red_Hat_Enterprise_Linux_OpenStack_Platform/.

The instance's flavor (see Section 3.3.4, “Update Flavor Metadata” )

The instance's image (see Appendix A, Image Configuration Parameters).

All available filters are listed in the following table.

Table 3.4 . Scheduling Filters

Filt er Descript ion

Ag g reg ateCo reFilter

Uses the ho st-ag g reg ate metad ata key 
cpu_allocation_ratio  to  fi l ter o ut ho sts exceed ing  the
o ver-co mmit ratio  (virtual CPU to  p hysical CPU allo catio n
ratio ); o nly valid  if a ho st ag g reg ate is  sp ecified  fo r the
instance.

If this  ratio  is  no t set, the fi l ter uses the 
cpu_allocation_ratio  value in the 
/etc/nova/nova.conf fi le. The d efault value is  '16 .0 '  (16
virtual CPU can b e allo cated  p er p hysical CPU).

Ag g reg ateDiskFilter

Uses the ho st-ag g reg ate metad ata key 
disk_allocation_ratio  to  fi l ter o ut ho sts exceed ing
the o ver-co mmit ratio  (virtual d isk to  p hysical d isk allo catio n
ratio ); o nly valid  if a ho st ag g reg ate is  sp ecified  fo r the
instance.

If this  ratio  is  no t set, the fi l ter uses the 
disk_allocation_ratio  value in the 
/etc/nova/nova.conf fi le. The d efault value is  '1.0 '  (o ne
virtual d isk can b e allo cated  fo r each p hysical d isk).

scheduler_default_filters=RetryFilter,AvailabilityZoneFilter,RamFilter
,ComputeFilter,ComputeCapabilitiesFilter,ImagePropertiesFilter,Server
GroupAntiAffinityFilter,ServerGroupAffinityFilter
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Ag g reg ateImag ePro p ertiesI
so latio n

Only p asses ho sts in ho st ag g reg ates who se metad ata
matches the instance's imag e metad ata; o nly valid  if a ho st
ag g reg ate is  sp ecified  fo r the instance. Fo r mo re info rmatio n,
see Sectio n 4.1.1, “ Create an Imag e” .

Ag g reg ateInstanceExtraSp e
csFilter

Metad ata in the ho st ag g reg ate must match the ho st's  flavo r
metad ata. Fo r mo re info rmatio n, see Sectio n 3.3.4, “ Up d ate
Flavo r Metad ata” .

Ag g reg ateMultiTenancyIso la
tio n

A ho st with the sp ecified  filter_tenant_id  can o nly
co ntain instances fro m that tenant (p ro ject). Not e: The tenant
can sti l l  p lace instances o n o ther ho sts.

Ag g reg ateRamFilter

Uses the ho st-ag g reg ate metad ata key 
ram_allocation_ratio  to  fi l ter o ut ho sts exceed ing  the
o ver co mmit ratio  (virtual RAM to  p hysical RAM allo catio n
ratio ); o nly valid  if a ho st ag g reg ate is  sp ecified  fo r the
instance.

If this  ratio  is  no t set, the fi l ter uses the 
ram_allocation_ratio  value in the 
/etc/nova/nova.conf fi le. The d efault value is  '1.5'  (1.5
RAM can b e allo cated  fo r each p hysical RAM).

AllHo stsFilter Passes all availab le ho sts (ho wever, d o es no t d isab le o ther
fi l ters).

Availab il i tyZo neFilter Filters using  the instance's sp ecified  availab il i ty zo ne.

Co mp uteCap ab il itiesFilter Ensures Co mp ute metad ata is  read  co rrectly. Anything  b efo re
the ' :'  is  read  as a namesp ace. Fo r examp le,
'q uo ta:cp u_p erio d '  uses 'q uo ta'  as the namesp ace and
'cp u_p erio d '  as the key.

Co mp uteFilter Passes o nly ho sts that are o p eratio nal and  enab led .

Co reFilter Uses the cpu_allocation_ratio  in the 
/etc/nova/nova.conf fi le to  fi l ter o ut ho sts exceed ing
the o ver co mmit ratio (virtual CPU to  p hysical CPU allo catio n
ratio ). The d efault value is  '16 .0 '  (16  virtual CPU can b e
allo cated  p er p hysical CPU).

DifferentHo stFilter Enab les an instance to  b uild  o n a ho st that is  d ifferent fro m
o ne o r mo re sp ecified  ho sts. Sp ecify 'd ifferent'  ho sts using
the nova boot o p tio n --different_host o p tio n.

Filt er Descript ion
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DiskFilter Uses disk_allocation_ratio  in the 
/etc/nova/nova.conf fi le to  fi l ter o ut ho sts exceed ing
the o ver co mmit ratio (virtual d isk to  p hysical d isk allo catio n
ratio ). The d efault value is  '1.0 '  (o ne virtual d isk can b e
allo cated  fo r each p hysical d isk).

Imag ePro p ertiesFilter Only p asses ho sts that match the instance's imag e
p ro p erties. Fo r mo re info rmatio n, see Sectio n 4.1.1, “ Create
an Imag e” .

Iso lated Ho stsFilter Passes o nly iso lated  ho sts running  iso lated  imag es that are
sp ecified  in the /etc/nova/nova.conf fi le us ing  
isolated_hosts and  isolated_images (co mma-
sep arated  values).

Jso nFilter

Reco g nises and  uses an instance's custo m JSON fi lters:

Valid  o p erato rs are: =, < , > , in, <=, >=, no t, o r, and

Reco g nised  variab les are: $free_ram_mb, 
$free_disk_mb, $total_usable_ram_mb, 
$vcpus_total , $vcpus_used

The fi l ter is  sp ecfied  as a q uery hint in the nova boot
co mmand . Fo r examp le:

--hint query='['>=', '$free_disk_mb', 200 
* 1024]'

MetricFilter Filters o ut ho sts with unavailab le metrics.

NUMATo p o lo g yFilter Filters o ut ho sts b ased  o n its  NUMA to p o lo g y; if the instance
has no  to p o lo g y d efined , any ho st can b e used . The fi l ter
tries to  match the exact NUMA to p o lo g y o f the instance to
tho se o f the ho st (it d o es no t attemp t to  p ack the instance
o nto  the ho st). The fi l ter also  lo o ks at the stand ard  o ver-
sub scrip tio n l imits  fo r each NUMA no d e, and  p ro vid es l imits
to  the co mp ute ho st acco rd ing ly.

RamFilter Uses ram_allocation_ratio  in the 
/etc/nova/nova.conf fi le to  fi l ter o ut ho sts exceed ing
the o ver co mmit ratio  (virtual RAM to  p hysical RAM allo catio n
ratio ). The d efault value is  '1.5'  (1.5 RAM can b e allo cated  fo r
each p hysical RAM).

RetryFilter Filters o ut ho sts that have failed  a sched uling  attemp t; valid  if 
scheduler_max_attempts is  g reater than zero  (b y
d efault,scheduler_max_attempts=3).

Filt er Descript ion
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SameHo stFilter

Passes o ne o r mo re sp ecified  ho sts; sp ecify ho sts fo r the
instance using  the --hint same_host o p tio n fo r nova 
boot.

ServerGro up AffinityFilter

Only p asses ho sts fo r a sp ecific  server g ro up :

G ive the server g ro up  the affinity p o licy (nova server-
group-create --policy affinity groupName).

Build  the instance with that g ro up  (nova boot o p tio n --
hint group=UUID).

ServerGro up AntiAffinityFilter

Only p asses ho sts in a server g ro up  that d o  no t alread y ho st
an instance:

G ive the server g ro up  the anti-affinity p o licy (nova 
server-group-create --policy anti-
affinity groupName).

Build  the instance with that g ro up  (nova boot o p tio n --
hint group=UUID).

Simp leCIDRAffinityFilter

Only p asses ho sts o n the sp ecified  IP sub net rang e
sp ecified  b y the instance's cidr and  
build_new_host_ip hints. Examp le:

--hint build_near_host_ip=192.0.2.0 --hint 
cidr=/24

Filt er Descript ion

3.5.2. Configure Scheduling Weights

Both cells and hosts can be weighted for scheduling; the host or cell with the largest weight
(after filtering) is selected. All weighers are given a multiplier that is applied after normalising
the node's weight. A node's weight is calculated as:

w1_multiplier * norm(w1) + w2_multiplier * norm(w2) + ...

You can configure weight options in the scheduler host's /etc/nova/nova.conf file
(must have either root or nova user permissions).

3.5 .2 .1 . Co nfigure Weight  Opt io ns fo r Ho st s
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You can define the host weighers you would like the scheduler to use in the [DEFAULT] 
scheduler_weight_classes option. Valid weighers are:

nova.scheduler.weights.ram - Weighs the host's available RAM.

nova.scheduler.weights.metrics - Weighs the host's metrics.

nova.scheduler.weights.all_weighers - Uses all host weighers (default).

Table 3.5. Host  Weight  Opt ions

Weighe
r

Opt ion Descript ion

All [DEFAULT]
sched uler_ho st_sub set_si
ze

Defines the sub set s ize fro m which a ho st is
selected  (integ er); must b e at least 1. A value o f 1
selects the firs t ho st returned  b y the weig hing
functio ns. Any value less than 1 is  ig no red  and  1 is
used  instead  (integ er value).

metrics [metrics] req uired

Sp ecifies ho w to  hand le metrics in [metrics] 
weight_setting  that are unavailab le:

True - Metrics are req uired ; if unavailab le, an
excep tio n is  raised . To  avo id  the excep tio n, use
the MetricFilter fi l ter in the 
[DEFAULT]scheduler_default_filters
o p tio n.

False - The unavailab le metric  is  treated  as a
neg ative facto r in the weig hing  p ro cess; the
returned  value is  set b y 
weight_of_unavailable.

metrics [metrics]
weig ht_o f_unavailab le

Used  as the weig ht if any metric  in [metrics] 
weight_setting  is  unavailab le; valid  if 
[metrics]required=False.

metrics [metrics] weig ht_multip lier Mulitp lier used  fo r weig hing  metrics. By d efault, 
weight_multiplier=1.0  and  sp read s
instances acro ss p o ssib le ho sts. If this  value is
neg ative, the ho st with lo wer metrics is  p rio ritized ,
and  instances are stacked  in ho sts.
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metrics [metrics] weig ht_setting

Sp ecifies metrics and  the ratio  with which they are
weig hed ; use a co mma-sep arated  l is t o f
'metric=ratio '  p airs. Valid  metric  names are:

cpu.frequency - Current CPU freq uency

cpu.user.time - CPU user mo d e time

cpu.kernel.time - CPU kernel time

cpu.idle.time - CPU id le time

cpu.iowait.time - CPU I/O  wait time

cpu.user.percent - CPU user mo d e
p ercentag e

cpu.kernel.percent - CPU kernel
p ercentag e

cpu.idle.percent - CPU id le p ercentag e

cpu.iowait.percent - CPU I/O  wait
p ercentag e

cpu.percent - Generic  CPU uti l izatio n

Examp le: 
weight_setting=cpu.user.time=1.0

ram [DEFAULT]
ram_weig ht_multip lier

Multip lier fo r RAM (flo ating  p o int). By d efault, 
ram_weight_multiplier=1.0  and  sp read s
instances acro ss p o ssib le ho sts. If this  value is
neg ative, the ho st with less RAM is p rio ritized , and
instances are stacked  in ho sts.

Weighe
r

Opt ion Descript ion

3.5 .2 .2 . Co nfigure Weight  Opt io ns fo r Cells

You define which cell weighers you would like the scheduler to use in the [cells] 
scheduler_weight_classes option (/etc/nova/nova.conf file; you must have either 
root or nova user permissions)

Valid weighers are:

nova.cells.weights.all_weighers - Uses all cell weighers(default).
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nova.cells.weights.mute_child - Weighs whether a child cell has not sent capacity or
capability updates for some time.

nova.cells.weights.ram_by_instance_type - Weighs the cell's available RAM.

nova.cells.weights.weight_offset - Evaluates a cell's weight offset. Note: A cell's weight
offset is specified using --woffset in the nova-manage cell create command.

Table 3.6 . Cell Weight  Opt ions

Weighers Opt ion Descript ion

mute_child [cells ]
mute_weig ht_mult
ip lier

Multip lier fo r ho sts which have b een s ilent fo r
so me time (neg ative flo ating  p o int). By d efault, this
value is  ' -10 .0 ' .

mute_child [cells ]
mute_weig ht_valu
e

Weig ht value g iven to  s ilent ho sts (p o sitive flo ating
p o int). By d efault, this  value is  '10 0 0 .0 ' .

ram_b y_instance
_typ e

[cells ]
ram_weig ht_multi
p lier

Multip lier fo r weig hing  RAM (flo ating  p o int). By
d efault, this  value is  '1.0 ' , and  sp read s instances
acro ss p o ssib le cells . If this  value is  neg ative, the
cell with fewer RAM is p rio ritized , and  instances
are stacked  in cells .

weig ht_o ffset [cells ]
o ffset_weig ht_mul
tip lier

Multip lier fo r weig hing  cells  (flo ating  p o int).
Enab les the instance to  sp ecify a p referred  cell
(flo ating  p o int) b y setting  its  weig ht o ffset to
9 9 9 9 9 9 9 9 9 9 9 9 9 9 9  (hig hest weig ht is
p rio ritized ). By d efault, this  value is  '1.0 ' .

3.6. EVACUATE INSTANCES

If you want to move an instance from a dead or shut-down compute node to a new host
server in the same environment (for example, because the server needs to be swapped out),
you can evacuate it using nova evacuate.

An evacuation is only useful if the instance disks are on shared storage or if the instance
disks are Block Storage volumes. Otherwise, the disks will not be accessible and cannot
be accessed by the new compute node.

An instance can only be evacuated from a server if the server is shut down; if the server is
not shut down, the evacuate command will fail.
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Note

If you have a functioning compute node, and you want to:

Make a static copy (not running) of an instance for backup purposes or to copy
the instance to a different environment, make a snapshot using nova image-
create (see Migrate a Static Instance).

Move an instance in a static state (not running) to a host in the same
environment (shared storage not needed), migrate it using nova migrate (see
Migrate a Static Instance).

Move an instance in a live state (running) to a host in the same environment,
migrate it using nova live-migration (see Migrate a Live (running)
Instance).

3.6.1. Evacuate One Instance

Evacuate an instance using:

# nova evacuate [--password pass] [--on-shared-storage] 
instance_name [target_host]

Where:

--password pass - Admin password to set for the evacuated instance (cannot be used
if --on-shared-storage is specified). If a password is not specified, a random
password is generated and output when evacuation is complete.

--on-shared-storage - Indicates that all instance files are on shared storage.

instance_name - Name of the instance to be evacuated.

target_host - Host to which the instance is evacuated; if you do not specify the host,
the Compute scheduler selects one for you. You can find possible hosts using:

# nova host-list | grep compute

For example:

# nova evacuate myDemoInstance Compute2_OnEL7.myDomain

3.6.2. Evacuate All Instances

Evacuate all instances on a specified host using:
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# nova host-evacuate instance_name [--target target_host] [--on-
shared-storage] source_host

Where:

--target target_host - Host to which the instance is evacuated; if you do not specify
the host, the Compute scheduler selects one for you. You can find possible hosts using:

# nova host-list | grep compute

--on-shared-storage - Indicates that all instance files are on shared storage.

source_host - Name of the host to be evacuated.

For example:

# nova host-evacuate --target Compute2_OnEL7.localdomain 
myDemoHost.localdomain

3.6.3. Configure Shared Storage

If you are using shared storage, this procedure exports the instances directory for the
Compute service to the two nodes, and ensures the nodes have access. The directory path is
set in the state_path and instances_path parameters in the /etc/nova/nova.conf
file. This procedure uses the default value, which is /var/lib/nova/instances. Only
users with root access can set up shared storage.

1. On the contro ller host :

a. Ensure the /var/lib/nova/instances directory has read-write access by
the Compute service user (this user must be the same across controller and
nodes). For example:

drwxr-xr-x.  9 nova nova 4096 Nov  5 20:37 instances

b. Add the following lines to the /etc/exports file; switch out node1_IP and
node2_IP for the IP addresses of the two compute nodes:

c. Export the /var/lib/nova/instances directory to the compute nodes.

# exportfs -avr

/var/lib/nova/instances 
node1_IP(rw,sync,fsid=0,no_root_squash)
/var/lib/nova/instances 
node2_IP(rw,sync,fsid=0,no_root_squash)
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d. Restart the NFS server:

# systemctl restart nfs-server

2. On each compute node:

a. Ensure the /var/lib/nova/instances directory exists locally.

b. Add the following line to the /etc/fstab file:

c. Mount the controller's instance directory (all devices listed in /etc/fstab ):

# mount -a -v

d. Ensure qemu can access the directory's images:

# chmod o+x /var/lib/nova/instances

e. Ensure that the node can see the instances directory with:

# ls -ld /var/lib/nova/instances
drwxr-xr-x. 9 nova nova 4096 Nov  5 20:37 
/var/lib/nova/instances

Note

You can also run the following to view all mounted devices:

# df -k

controllerName:/var/lib/nova/instances 
/var/lib/nova/instances nfs4 defaults 0 0
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CHAPTER 4. IMAGES AND STORAGE

This chapter discusses the steps you can follow to manage images and storage in RHEL
OpenStack Platform.

A virtual machine image is a file that contains a virtual disk which has a bootable operating
system installed on it. Virtual machine images are supported in different formats. The
following are the formats available on RHEL OpenStack Platform:

RAW - Unstructured disk image format.

QCOW2 - Disk format supported by QEMU emulator.

ISO  - Sector-by-sector copy of the data on a disk, stored in a binary file.

AKI - Indicates an Amazon Kernel Image.

AMI - Indicates an Amazon Machine Image.

ARI - Indicates an Amazon RAMDisk Image.

VDI - Disk format supported by VirtualBox virtual machine monitor and the QEMU
emulator.

VHD  - Common disk format used by virtual machine monitors from VMWare, VirtualBox,
and others.

VMDK - Disk format supported by many common virtual machine monitors.

While we don't normally think of ISO as a virtual machine image format, since ISOs contain
bootable filesystems with an installed operating system, you can treat them the same as you
treat other virtual machine image files.

To download the official Red Hat Enterprise Linux cloud images, you require a valid Red Hat
Enterprise Linux subscription:

Red Hat Enterprise Linux 7 KVM Guest Image

Red Hat Enterprise Linux 6 KVM Guest

4.1. MANAGE IMAGES

The OpenStack Image service (glance) provides discovery, registration, and delivery
services for disk and server images. It provides the ability to copy or snapshot a server
image, and immediately store it away. Stored images can be used as a template to get new
servers up and running quickly and more consistently than installing a server operating
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system and individually configuring additional services.

4 .1.1. Create an Image

This section provides you with the steps to manually create an OpenStack-compatible image
in .qcow2 format using a Red Hat Enterprise Linux 7 ISO file.

Prerequisites:

Linux host machine to create an image. This can be any machine on which you can
install and run the Linux packages.

libvirt, virt-manager (run command yum groupinstall -y @virtualization). This
installs all packages necessary for creating a guest operating system.

Libguestfs tools (run command yum install -y libguestfs-tools-c). This
installs a set of tools for accessing and modifying virtual machine images.

A Red Hat Enterprise Linux 7 ISO file (see Get Installation Media).

Text editor, if you want to change the kickstart files.

Procedure 4 .1. Create an Image

1. Start the installation using virt-install  as shown below:

# qemu-img create -f qcow2 rhel7.qcow2 8G
# virt-install --virt-type kvm --name rhel7 --ram 2048 \
--cdrom /tmp/rhel-server-7.0-x86_64-dvd.iso --disk 
rhel7.qcow2,format=qcow2 \
--network=bridge:virbr0 --graphics vnc,listen=0.0.0.0 \
--noautoconsole --os-type=linux --os-variant=rhel7

This launches an instance and starts the installation process.

2. After the installation is complete, reboot the instance and log in as the root user.

3. Update the /etc/sysconfig/network-scripts/ifcfg-eth0  file so it only
contains the following values:

4. Reboot the machine.

TYPE=Ethernet
DEVICE=eth0
ONBOOT=yes
BOOTPROTO=dhcp
NM_CONTROLLED=no
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Note

Ensure you are subscribed to RHEL 7 using subscription-manager. For
more information, see Software Repository Configuration

5. Update the system.

# yum -y update

6. Install the cloud-init packages and git.

# yum install -y cloud-utils-growpart cloud-init

7. Edit the /etc/cloud/cloud.cfg  configuration file and under 
cloud_init_modules add:

8. Add the following line to /etc/sysconfig/network to avoid problems accessing
the EC2 metadata service.

9. Power off the instance:

# poweroff

10. Reset and clean the image using the virt-sysprep command so it can be to create
instances without issues:

# virt-sysprep -d rhel7

11. Reduce image size using the virt-sparcify command. This command converts
any free space within the disk image back to free space within the host:

# virt-sparsify --compress /tmp/rhel7.qcow2 rhel7-cloud.qcow2

The underlying image file that you created with qemu-img create is now ready to be
uploaded to the Image service. For more information on uploading this image to your
OpenStack deployment using the dashboard, see Section 4.1.2, “Upload an Image” .

4 .1.2. Upload an Image

1. In the dashboard, select Project > Compute > Images.

- resolv-conf

NOZEROCONF=yes
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2. Click Create Image.

3. Fill out the values, and click Create Image when finished.

Field Not es

Name Name fo r the imag e. The name must b e uniq ue within the
p ro ject.

Descrip tio n Brief d escrip tio n to  id entify the imag e.

Imag e So urce

Imag e so urce: Image Location o r Image File.
Based  o n yo ur selectio n, the next field  is  d isp layed .

Imag e Lo catio n o r
Imag e File Select Image Location o p tio n to  sp ecify the imag e

lo catio n URL.

Select Image File o p tio n to  up lo ad  an imag e fro m
the lo cal d isk.

Fo rmat Imag e fo rmat (fo r examp le, q co w2).

Architecture Imag e architecture. Fo r examp le, use i6 8 6  fo r a 32-b it
architecture o r x8 6 _6 4 fo r a 6 4-b it architecture.

Minimum Disk (GB) Minimum d isk s ize req uired  to  b o o t the imag e. If this  field
is  no t sp ecified , the d efault value is  0  (no  minimum).

Minimum RAM (MB) Minimum memo ry s ize req uired  to  b o o t the imag e. If this
field  is  no t sp ecified , the d efault value is  0  (no  minimum).

Pub lic If selected , makes the imag e p ub lic  to  all users with
access to  the p ro ject.

Pro tected If selected , ensures o nly users with sp ecific  p ermissio ns
can d elete this  imag e.

Note

You can also use the glance image-create command with the property
option to create an image. More values are available on the commmand line. For a
complete listing, see Appendix A, Image Configuration Parameters.

4 .1.3. Update an Image

1. In the dashboard, select Project > Compute > Images.
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2. Click Edit.

Note

The Edit option is available only when you login as an admin user. When
you login as a demo  user, you have the option to Launch an instance or 
Create Volume.

3. Update the fields and click Update Image when finished. You can update the
following values - name, description, kernel ID, ramdisk ID, architecture, format,
minimum disk, minimum RAM, public, protected.

4. Click the dropdown menu and select Update Metadata option.

5. Specify metadata by adding items from the left column to the right one. In the left
column, there are metadata definitions from the Image Service Metadata Catalog.
Select Other to add metadata with the key of your choice and click Save when
finished.

Note

You can also use the glance image-update command with the property
option to update an image. More values are available on the commmand line; for a
complete listing, see Appendix A, Image Configuration Parameters.

4 .1.4 . Delete an Image

1. In the dashboard, select Project > Compute > Images.

2. Select the image you want to delete and click Delete Images.

4.2. MANAGE VOLUMES

A volume is a block storage device that provides persistent storage to OpenStack instances.

4 .2.1. Basic Volume Usage and Configurat ion

The following procedures describe how to perform basic end-user volume management.
These procedures do not require administrative privileges.

4.2 .1 .1 . Creat e a Vo lume

1. In the dashboard, select Project > Compute > Volumes.

2. Click Create Volume , and edit the following fields:
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Field Descript ion

Vo lume
name

Name o f the vo lume.

Descrip tio n Op tio nal, sho rt d escrip tio n o f the vo lume.

Typ e

Op tio nal vo lume typ e (see Sectio n 4.2.4, “ Gro up  Vo lume Setting s
with Vo lume Typ es” ).

If yo u have multip le Blo ck Sto rag e b ack end s, yo u can use this  to
select a sp ecific  b ack end . See Sectio n 4.2.1.2, “ Sp ecify Back End  fo r
Vo lume Creatio n”  fo r d etails .

Size (GB) Vo lume s ize (in g ig ab ytes).

Availab il i ty
Zo ne Availab il i ty zo nes (lo g ical server g ro up s), alo ng  with ho st

ag g reg ates, are a co mmo n metho d  fo r seg reg ating  reso urces within
Op enStack. Availab il i ty zo nes are d efined  d uring  installatio n. Fo r
mo re info rmatio n o n availab il i ty zo nes and  ho st ag g reg ates, see
Sectio n 3.4, “ Manag e Ho st Ag g reg ates” .

3. Specify a Volume Source:

Source Descript ion

No
so urce,
emp ty
vo lume

The vo lume wil l b e emp ty, and  wil l no t co ntain a fi le system o r p artitio n
tab le.

Snap sho t

Use an existing  snap sho t as a vo lume so urce. If yo u select this  o p tio n,
a new Use snapshot as a source l is t ap p ears; yo u can then
cho o se a snap sho t fro m the l is t. Fo r mo re info rmatio n ab o ut vo lume
snap sho ts, refer to  Sectio n 4.2.1.8 , “ Create, Clo ne, o r Delete Vo lume
Snap sho ts” .

Imag e Use an existing  imag e as a vo lume so urce. If yo u select this  o p tio n, a
new Use image as a source l is ts  ap p ears; yo u can then cho o se
an imag e fro m the l is t.

Vo lume Use an existing  vo lume as a vo lume so urce. If yo u select this  o p tio n, a
new Use volume as a source l is t ap p ears; yo u can then cho o se
a vo lume fro m the l is t.

4. Click Create Volume. After the volume is created, its name appears in the Volumes
table.
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4.2 .1 .2 . Specify Back End fo r Vo lume Creat io n

You can configure the Block Storage service to use multiple back ends. For example,
Configure OpenStack to Use an NFS Back End provides step-by-step instructions on how to
configure the Block Storage service to use an NFS share alongside the default back end.

Whenever multiple Block Storage back ends are configured, you will also need to create a
volume type for each back end. You can then use the type to specify which back end should
be used for a created volume. For more information about volume types, see Section 4.2.4,
“Group Volume Settings with Volume Types” .

To specify a back end when creating a volume, select its corresponding volume type from the
Type drop-down list (see Section 4.2.1.1, “Create a Volume” ).

If you do not specify a back end during volume creation, the Block Storage service will
automatically choose one for you. By default, the service will choose the back end with the
most available free space. You can also configure the Block Storage service to choose
randomly among all available back ends instead; for more information, see Section 4.2.7,
“Configure How Volumes are Allocated to Multiple Back Ends” .

4.2 .1 .3. Edit  a Vo lume's Name o r Descript io n

1. In the dashboard, select Project > Compute > Volumes.

2. Select the volume's Edit Volume button.

3. Edit the volume name or description as required.

4. Click Edit Volume to save your changes.

Note

To create an encrypted volume, you must first have a volume type configured
specifically for volume encryption. In addition, both Compute and Block Storage
services must be configured to use the same static key. For information on how to
set up the requirements for volume encryption, refer to Section 4.2.6, “Encrypt
Volumes with Static Keys” .

4.2 .1 .4 . Delet e  a Vo lume

1. In the dashboard, select Project > Compute > Volumes.

2. In the Volumes  table, select the volume to delete.

3. Click Delete Volumes .
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Note

A volume cannot be deleted if it has existing snapshots. For instructions on how to
delete snapshots, see Section 4.2.1.8, “Create, Clone, or Delete Volume
Snapshots” .

4.2 .1 .5 . At t ach and Det ach a Vo lume t o  an Inst ance

Instances can use a volume for persistent storage. A volume can only be attached to one
instance at a time. For more information on instances, see Section 3.1, “Manage Instances” .

Procedure 4 .2. At tach a Volume f rom an Instance

1. In the dashboard, select Project > Compute > Volumes.

2. Select the volume's Edit Attachments action. If the volume is not attached to an
instance, the Attach To Instance drop-down list is visible.

3. From the Attach To Instance list, select the instance to which you wish to attach
the volume.

4. Click Attach Volume.

Procedure 4 .3. Detach a Volume From an Instance

1. In the dashboard, select Project > Compute > Volumes.

2. Select the volume's Edit Attachments action. If the volume is attached to an
instance, the instance's name is displayed in the Attachments table.

3. Click Detach Volume in this and the next dialog screen.

4.2 .1 .6 . Set  a Vo lume t o  Read-Only

You can give multiple users shared access to a single volume without allowing them to edit
its contents. To do so, set the volume to read-only using the following command:

# cinder readonly-mode-update VOLUME true

Replace VOLUME with the ID of the target volume.

To set a read-only volume back to read-write, run:

# cinder readonly-mode-update VOLUME false
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4.2 .1 .7 . Change a Vo lume's Owner

To change a volume's owner, you will have to perform a volume transfer. A volume transfer is
initiated by the volume's owner, and the volume's change in ownership is complete after the
transfer is accepted by the volume's new owner.

1. From the command line, log in as the volume's current owner.

2. List the available volumes:

# cinder list

3. Initiate the volume transfer:

# cinder transfer-create VOLUME

Where VOLUME is the name or ID of the volume you wish to transfer.

Example 4 .1. 

# cinder transfer-create samplevolume
+------------+--------------------------------------+
|  Property  |                Value                 |
+------------+--------------------------------------+
|  auth_key  |           f03bf51ce7ead189           |
| created_at |      2014-12-08T03:46:31.884066      |
|     id     | 3f5dc551-c675-4205-a13a-d30f88527490 |
|    name    |                 None                 |
| volume_id  | bcf7d015-4843-464c-880d-7376851ca728 |
+------------+--------------------------------------+

The cinder transfer-create command clears the ownership of the volume and
creates an id  and auth_key for the transfer. These values can be given to, and
used by, another user to accept the transfer and become the new owner of the
volume.

4. The new user can now claim ownership of the volume. To do so, the user should first
log in from the command line and run:

# cinder transfer-accept TRANSFERID TRANSFERKEY

Where TRANSFERID and TRANSFERKEY are the id  and auth_key values returned
by the cinder transfer-create command, respectively.

Example 4 .2. 
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# cinder transfer-accept 3f5dc551-c675-4205-a13a-
d30f88527490 f03bf51ce7ead189

Note

You can view all available volume transfers using:

# cinder transfer-list

4.2 .1 .8 . Creat e, Clo ne, o r Delet e  Vo lume Snapsho t s

You can preserve a volume's state at a specific point in time by creating a volume snapshot.
You can then use the snapshot to clone new volumes.

Note

Volume backups are different from snapshots. Backups preserve the data
contained in the volume, whereas snapshots preserve the state of a volume at a
specific point in time. In addition, you cannot delete a volume if it has existing
snapshots. Volume backups are used to prevent data loss, whereas snapshots are
used to facilitate cloning.

For more information about volume backups, refer to Section 4.2.2, “Back Up and
Restore a Volume” .

To create a volume snapshot:

1. In the dashboard, select Project > Compute > Volumes.

2. Select the target volume's Create Snapshot action.

3. Provide a Snapshot Name for the snapshot and click Create a Volume 
Snapshot. The Volume Snapshots tab displays all snapshots.

You can clone new volumes from a snapshot once it appears in the Volume Snapshots
table. To do so, select the snapshot's Create Volume action. For more information about
volume creation, see Section 4.2.1.1, “Create a Volume” .

Warning

Creating a snapshot of a volume that is attached to an instance may corrupt the
snapshot. For instructions on how to detach a volume from an instance, see
Procedure 4.3, “Detach a Volume From an Instance” .
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To delete a snapshot, select its Delete Volume Snapshot action.

If your OpenStack deployment uses a Red Hat Ceph back end, see Section 4.2.1.8.1,
“Protected and Unprotected Snapshots in a Red Hat Ceph Back End”  for more information
on snapshot security and troubleshooting.

4 .2.1.8.1. Protected and Unprotected Snapshots in  a Red Hat  Ceph Back End

When using Red Hat Ceph as a back end for your OpenStack deployment, you can set a
snapshot to protected in the back end. Attempting to delete protected snapshots through
OpenStack (as in, through the dashboard or the cinder snapshot-delete command)
will fail.

When this occurs, set the snapshot to unprotected in the Red Hat Ceph back end first.
Afterwards, you should be able to delete the snapshot through OpenStack as normal.

For related instructions, see Protecting a Snapshot and Unprotecting a Snapshot.

4.2 .1 .9 . Uplo ad a Vo lume t o  t he Image Service

You can upload an existing volume as an image to the Image service directly. To do so:

1. In the dashboard, select Project > Compute > Volumes.

2. Select the target volume's Upload to Image action.

3. Provide an Image Name for the volume and select a Disk Format from the list.

4. Click Upload . The QEMU disk image utility uploads a new image of the chosen
format using the name you provided.

To view the uploaded image, select Project > Compute > Images. The new image
appears in the Images table. For information on how to use and configure images, see
Section 4.1, “Manage Images” .

4 .2.2. Back Up and Restore a Volume

A volume backup is a full, persistent copy of a volume's contents. Volume backups are
typically created as object stores, and therefore are managed through the Object Storage
service.

When creating a volume backup, all of the backup's metadata is stored in the Block Storage
service's database. The cinder utility uses this metadata when restoring a volume from the
backup. As such, when recovering from a catastrophic database loss, you must restore the
Block Storage service's database first before restoring any volumes from backups. This also
presumes that the Block Storage service database is being restored with all the original
volume backup metadata intact.
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If you wish to configure only a subset of volume backups to survive a catastrophic database
loss, you can also export the backup's metadata. In doing so, you can then re-import the
metadata to the Block Storage database later on, and restore the volume backup as normal.

Note

Volume backups are different from snapshots. Backups preserve the data
contained in the volume, whereas snapshots preserve the state of a volume at a
specific point in time. In addition, you cannot delete a volume if it has existing
snapshots. Volume backups are used to prevent data loss, whereas snapshots are
used to facilitate cloning.

For more information about volume snapshots, refer to Section 4.2.1.8, “Create,
Clone, or Delete Volume Snapshots” .

4.2 .2 .1 . Creat e a Vo lume Backup

1. As a user with administrative privileges, view the ID  or Display Name of the volume
you wish to back-up:

# cinder list

2. Back up the volume:

# cinder backup-create VOLUME

Where VOLUME is the ID  or Display Name of the volume you wish to back-up.

Example 4 .3. 

# cinder backup-create volumename
+-----------+--------------------------------------+
|  Property |                Value                 |
+-----------+--------------------------------------+
|     id    | e9d15fc7-eeae-4ca4-aa72-d52536dc551d |
|    name   |                 None                 |
| volume_id | 5f75430a-abff-4cc7-b74e-f808234fa6c5 |
+-----------+--------------------------------------+

Note that the volume_id  of the resulting backup is identical to the ID  of 
volumename.

3. Verify that the volume backup creation is complete:

# cinder backup-list
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The volume backup creation is complete when the Status of the backup entry is 
available.

At this point, you can also export and store the volume backup's metadata. This allows you
to restore the volume backup, even if the Block Storage database suffers a catastrophic loss.
To do so, run:

# cinder --os-volume-api-version 2 backup-export BACKUPID

Where BACKUPID is the ID or name of the volume backup.

Example 4 .4 . 

# cinder --os-volume-api-version 2 backup-export e9d15fc7-eeae-
4ca4-aa72-d52536dc551d
+----------------+-----------------------------------------------
-------------------+
|    Property    |                                    Value                         
|
+----------------+-----------------------------------------------
-------------------+
| backup_service |                         
cinder.backup.drivers.swift              |
|   backup_url   | eyJzdGF0dXMi...                                                  
|
|                | ...c2l6ZSI6IDF9                                                  
|
+----------------+-----------------------------------------------
-------------------+

The volume backup metadata consists of the backup_service and backup_url  values.

4.2 .2 .2 . Rest o re a Vo lume Aft er a Blo ck St o rage Dat abase Lo ss

Typically, a Block Storage database loss prevents you from restoring a volume backup. This
is because the Block Storage database contains metadata required by the volume backup.
This metadata consists of backup_service and backup_url  values, which you can
export after creating the volume backup (as shown in Section 4.2.2.1, “Create a Volume
Backup” ).

If you exported and stored this metadata, then you can import it to a new Block Storage
database (thereby allowing you to restore the volume backup).

1. As a user with administrative privileges, run:

# cinder --os-volume-api-version 2 backup-import 
backup_service backup_url 
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Where backup_service and backup_url are from the metadata you exported.

Example 4 .5. 

Using the exported sample metadata from Section 4.2.2.1, “Create a Volume
Backup” :

# cinder --os-volume-api-version 2 backup-import 
cinder.backup.drivers.swift eyJzdGF0dXMi...c2l6ZSI6IDF9
+----------+--------------------------------------+
| Property |                Value                 |
+----------+--------------------------------------+
|    id    | 77951e2f-4aff-4365-8c64-f833802eaa43 |
|   name   |                 None                 |
+----------+--------------------------------------+

2. After the metadata is imported into the Block Storage service database, you can
restore the volume as normal (see Section 4.2.2.3, “Restore a Volume from a
Backup” ).

4.2 .2 .3. Rest o re a Vo lume fro m a Backup

1. As a user with administrative privileges, find the ID  of the volume backup you wish to
use:

# cinder backup-list

The Volume ID  should match the ID of the volume you wish to restore.

2. Restore the volume backup:

# cinder backup-restore BACKUP_ID

Where BACKUP_ID is the ID of the volume backup you wish to use.

3. If you no longer need the backup, delete it:

# cinder backup-delete BACKUP_ID

4 .2.3. Migrate a Volume

Only an administrator can migrate volumes; volumes to be migrated cannot be in use nor
can they have any snapshots.

1. As an administrative user, list all available volumes:
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# cinder list

2. List the available back ends (hosts) and their respective availability zones:

# cinder-manage host list

3. Initiate the migration:

# cinder migrate VOLUME BACKEND

Where:

VOLUME is the ID of the volume to be migrated.

BACKEND is the back end to where the volume should be migrated.

4. View the current status of the volume to be migrated:

# cinder show VOLUME

Example 4 .6 . 

# cinder show 45a85c3c-3715-484d-ab5d-745da0e0bd5a
+---------------------------------------+------------------
--------------------+
|                Property               |                
Value                 |
+---------------------------------------+------------------
--------------------+
|                  ...                  |                 
...                  |
|         os-vol-host-attr:host         |                
server1               |
|     os-vol-mig-status-attr:migstat    |                 
None                 |
|                  ...                  |                 
...                  |
+---------------------------------------+------------------
--------------------+

During migration, note the following attributes:

os-vol-host -at t r:host

The volume's current back end. Once the migration completes, this displays
the target back end (namely, BACKEND).
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os-vol-mig-status-at t r:migstat

The status of the migration. A status of None means a migration is no longer
in progress.

4 .2.4 . Group Volume Set t ings with Volume T ypes

OpenStack allows you to create volume types, which allows you apply the type's associated
settings when creating a volume (Section 4.2.1.1, “Create a Volume” ). For example, you can
associate:

Whether or not a volume is encrypted (Section 4.2.6.2, “Configure Volume Type
Encryption” )

Which back end a volume should use (Section 4.2.1.2, “Specify Back End for Volume
Creation” )

Quality-of-Service (QoS) Specs

Settings are associated with volume types using key-value pairs called Extra Specs. When
you specify a volume type during volume creation, the Block Storage scheduler applies
these key/value pairs as settings. You can associate multiple key/value pairs to the same
volume type.

Example 4 .7. 

Volume types provide the capability to provide different users with storage tiers. By
associating specific performance, resilience, and other settings as key/value pairs to a
volume type, you can map tier-specific settings to different volume types. You can then
apply tier settings when creating a volume by specifying the corresponding volume type.

Note

Available and supported Extra Specs vary per volume driver. Consult your volume
driver's documentation for a list of valid Extra Specs.

4.2 .4 .1 . Creat e and Co nfigure a Vo lume T ype

1. As an admin user in the dashboard, select Admin > Volumes > Volume Types.

2. Click Create Volume Type.

3. Enter the volume type name in the Name field.

4. Click Create Volume Type. The new type appears in the Volume Types table.
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5. Select the volume type's View Extra Specs action.

6. Click Create, and specify the Key and Value. The key/value pair must be valid;
otherwise, specifying the volume type during volume creation will result in an error.

7. Click Create. The associated setting (key/value pair) now appears in the Extra 
Specs table.

Note

You can also associate a QOS Spec to the volume type. For details, refer to
Section 4.2.5.2, “Associate a QOS Spec with a Volume Type” .

4.2 .4 .2 . Edit  a Vo lume T ype

1. As an admin user in the dashboard, select Admin > Volumes > Volume Types.

2. In the Volume Types table, select the volume type's View Extra Specs action.

3. On the Extra Specs table of this page, you can:

Add a new setting to the volume type. To do this, click Create, and specify the
key/value pair of the new setting you wish to associate to the volume type.

Edit an existing setting associated with the volume type. To do this, select the
settings Edit action.

Delete existing settings associated with the volume type. To do this, select the
extra specs' check box and click Delete Extra Specs in this and the next
dialog screen.

4.2 .4 .3. Delet e  a Vo lume T ype

To delete a volume type, select its corresponding checkboxes from the Volume Types table
and click Delete Volume Types.

4 .2.5. Use Quality-of-Service Specificat ions

You can map multiple performance settings to a single Quality-of-Service specification (QOS
Specs). Doing so allows you to provide performance tiers for different user types.

Performance settings are mapped as key/value pairs to QOS Specs, similar to the way
volume settings are associated to a volume type. However, QOS Specs are different from
volume types in the following respects:
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QOS Specs are used to apply performance settings, which include limiting read/write
operations to disks. Available and supported performance settings vary per storage
driver.

To determine which QOS Specs are supported by your back end, consult the
documentation of your back end device's volume driver.

Volume types are directly applied to volumes, whereas QOS Specs are not. Rather, QOS
Specs are associated to volume types. During volume creation, specifying a volume type
also applies the performance settings mapped to the volume type's associated QOS
Specs.

4.2 .5 .1 . Creat e and Co nfigure a QOS Spec

As an administrator, you can create and configure a QOS Spec through the QOS Specs
table. You can associate more than one key/value pair to the same QOS Spec.

1. As an admin user in the dashboard, select Admin > Volumes > Volume Types.

2. On the QOS Specs table, click Create QOS Spec.

3. Enter a name for the QOS Spec.

4. In the Consumer field, specify where the QOS policy should be enforced:

Table 4 .1. Consumer Types

T ype Descript ion

b ack-end QOS p o licy wil l b e ap p lied  to  the Blo ck Sto rag e b ack end .

fro nt-end QOS p o licy wil l b e ap p lied  to  Co mp ute.

b o th QOS p o licy wil l b e ap p lied  to  b o th Blo ck Sto rag e and
Co mp ute.

5. Click Create. The new QOS Spec should now appear in the QOS Specs table.

6. In the QOS Specs table, select the new spec's Manage Specs action.

7. Click Create, and specify the Key and Value. The key/value pair must be valid;
otherwise, specifying a volume type associated with this QOS Spec during volume
creation will fail.

8. Click Create. The associated setting (key/value pair) now appears in the Key-
Value Pairs table.
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4.2 .5 .2 . Asso ciat e  a QOS Spec wit h a Vo lume T ype

As an administrator, you can associate a QOS Spec to an existing volume type using the 
Volume Types table.

1. As an administrator in the dashboard, select Admin > Volumes > Volume 
Types.

2. In the Volume Types table, select the type's Manage QOS Spec Association
action.

3. Select a QOS Spec from the QOS Spec to be associated  list.

4. Click Associate. The selected QOS Spec now appears in the Associated QOS 
Spec column of the edited volume type.

4.2 .5 .3. Disasso ciat e  a QOS Spec fro m a Vo lume T ype

1. As an administrator in the dashboard, select Admin > Volumes > Volume 
Types.

2. In the Volume Types table, select the type's Manage QOS Spec Association
action.

3. Select 'None' from the QOS Spec to be associated  list.

4. Click Associate. The selected QOS Spec is no longer in the Associated QOS 
Spec column of the edited volume type.

4 .2.6. Encrypt  Volumes with Stat ic Keys

Volume encryption helps provide basic data protection in case the volume back-end is either
compromised or outright stolen. The contents of an encrypted volume can only be read with
the use of a specific key; both Compute and Block Storage services must be configured to
use the same key in order for instances to use encrypted volumes. This section describes
how to configure an OpenStack deployment to use a single key for encrypting volumes.

4.2 .6 .1 . Co nfigure a St at ic Key

The first step in implementing basic volume encryption is to set a static key. This key must be
a hex string, which will be used by the Block Storage volume service (namely, openstack-
cinder-volume) and all Compute services (openstack-nova-compute). To configure
both services to use this key, set the key as the fixed_key value in the [keymgr] section
of both service's respective configuration files.

1. From the command line, log in as root to the node hosting openstack-cinder-
volume.
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2. Set the static key:

# openstack-config --set /etc/cinder/cinder.conf keymgr 
fixed_key HEX_KEY

Replace HEX_KEY with a 16-digit alphanumeric hex key (for example, 
0000000000000000000000000000000000000000000000000000000
000000000 ).

3. Restart the Block Storage volume service:

# openstack-service restart cinder-volume

4. Log in to the node hosting openstack-nova-compute, and set the same static key:

# openstack-config --set /etc/nova/nova.conf keymgr fixed_key 
HEX_KEY

Note

If you have multiple Compute nodes (multiple nodes hosting openstack-
nova-compute), then you need to set the same static key in 
/etc/nova/nova.conf of each node.

5. Restart the Compute service:

# openstack-service restart nova-compute

Note

Likewise, if you set the static key on multiple Compute nodes, you need to
restart the openstack-nova-compute service on each node as well.

At this point, both Compute and Block Storage volume services can now use the same static
key to encrypt/decrypt volumes. That is, new instances will be able to use volumes encrypted
with the static key (HEX_KEY).

4.2 .6 .2 . Co nfigure Vo lume T ype Encrypt io n

To create volumes encrypted with the static key from Section 4.2.6.1, “Configure a Static
Key” , you need an encrypted volume type. Configuring a volume type as encrypted involves
setting what provider class, cipher, and key size it should use. To do so, run:

# cinder encryption-type-create --cipher aes-xts-plain64 --key_size 
BITSIZE --control_location front-end VOLTYPE 
nova.volume.encryptors.luks.LuksEncryptor
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Where:

BITSIZE is the key size (for example, 512 for a 512-bit key).

VOLTYPE is the name of the volume type you want to encrypt.

This command sets the nova.volume.encryptors.luks.LuksEncryptor provider
class and aes-xts-plain64  cipher. As of this release, this is the only supported
class/cipher configuration for volume encryption.

Once you have an encrypted volume type, you can invoke it to automatically create
encrypted volumes. Specifically, select the encrypted volume type from the Type  drop-down
list in the Create Volume  window (see to Section 4.2.1, “Basic Volume Usage and
Configuration” ).

4 .2.7. Configure How Volumes are Allocated to Mult iple Back Ends

If the Block Storage service is configured to use multiple back ends, you can use configured
volume types to specify where a volume should be created. For details, see Section 4.2.1.2,
“Specify Back End for Volume Creation” .

Conversely, you can also configure how the Block Storage service should choose a back
end if none is specified during volume creation. To do so:

1. Enable the FilterScheduler.

# openstack-config --set /etc/cinder/cinder.conf DEFAULT 
scheduler_driver 
cinder.scheduler.filter_scheduler.FilterScheduler
# openstack-config --set /etc/cinder/cinder.conf DEFAULT 
scheduler_default_filters 
AvailabilityZoneFilter,CapacityFilter,CapabilitiesFilter

The FilterScheduler uses the following filters to list all suitable back ends:

Availab ilityZoneFilter

Filters out all back ends that do not meet the availability zone requirements of
the requested volume

CapacityFilter

Selects only back ends with enough space to accommodate the volume

Capabilit iesFilter

Selects only back ends that can support any specified settings in the volume

Red Hat  Ent erprise Linux OpenSt ack Plat form 6  Administ rat ion Guide

72



2. Configure how the scheduler should select a suitable back end. If you want the
scheduler:

To always choose the back end with the most available free space, run:

# openstack-config --set /etc/cinder/cinder.conf DEFAULT 
scheduler_default_weighers AllocatedCapacityWeigher
# openstack-config --set /etc/cinder/cinder.conf DEFAULT 
sallocated_capacity_weight_multiplier -1.0

To choose randomly among all suitable back ends, run:

# openstack-config --set /etc/cinder/cinder.conf DEFAULT 
scheduler_default_weighers ChanceWeigher

3. Restart the Block Storage scheduler to apply your settings:

# openstack-service restart openstack-cinder-scheduler

4.3. MANAGE CONTAINERS

OpenStack Object Storage (swift) stores its objects (data) in containers, which are similar to
directories in a file system although they cannot be nested. Containers provide an easy way
for users to store any kind of unstructured data; for example, objects might include photos,
text files, or images. Stored objects are not encrypted nor are they compressed.

To help with organization, pseudo-folders are logical devices that can contain objects (and
can be nested). For example, you might create an 'Images' folder in which to store pictures
and a 'Media' folder in which to store videos.

You can create one or more containers in each project, and one or more objects or pseudo-
folders in each container.

4 .3.1. Create a Container

1. In the dashboard, select Project > Object Store > Containers.

2. Click Create Container.

3. Specify the Container Name, and select one of the following in the Container 
Access field.

T ype Descript ion

Privat
e

Limits access to  a user in the current p ro ject.
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Pub li
c

Permits API access to  anyo ne with the p ub lic  URL. Ho wever, in the
d ashb o ard , p ro ject users canno t see p ub lic  co ntainers and  d ata fro m o ther
p ro jects.

T ype Descript ion

4. Click Create Container.

4 .3.2. Create Pseudo Folder for Container

1. In the dashboard, select Project > Object Store > Containers.

2. Click the name of the container to which you want to add the pseudo-folder.

3. Click Create Pseudo-folder.

4. Specify the name in the Pseudo-folder Name field, and click Create.

4 .3.3. Upload an Object

If you do not upload an actual file, the object is still created (as placeholder) and can later
be used to upload the file.

1. In the dashboard, select Project > Object Store > Containers.

2. Click the name of the container in which the uploaded object will be placed; if a
pseudo-folder already exists in the container, you can click its name.

3. Browse for your file, and click Upload Object.

4. Specify a name in the Object Name field:

Pseudo-folders can be specified in the name using a ' /'  character (for example,
'Images/myImage.jpg'). If the specified folder does not already exist, it is created
when the object is uploaded.

A name that is not unique to the location (that is, the object already exists)
overwrites the object's contents.

5. Click Upload Object.

4 .3.4 . Copy an Object

1. In the dashboard, select Project > Object Store > Containers.
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2. Click the name of the object's container or folder (to display the object).

3. Click Upload Object.

4. Browse for the file to be copied, and select Copy in its arrow menu.

5. Specify the following:

Field Descript ion

Destinatio n
co ntainer

Targ et co ntainer fo r the new o b ject.

Path Pseud o -fo ld er in the d estinatio n co ntainer; if the fo ld er d o es
no t alread y exist, i t is  created .

Destinatio n o b ject
name New o b ject's  name. If yo u use a name that is  no t uniq ue to  the

lo catio n (that is , the o b ject alread y exists), it o verwrites the
o b ject's  p revio us co ntents.

6. Click Copy Object.

4 .3.5. Delete an Object

1. In the dashboard, select Project > Object Store > Containers.

2. Browse for the object, and select Delete Object in its arrow menu.

3. Click Delete Object to confirm the object's removal.

4 .3.6. Delete a Container

1. In the dashboard, select Project > Object Store > Containers.

2. Browse for the container in the Containers section, and ensure all objects have
been deleted (see Section 4.3.5, “Delete an Object” ).

3. Select Delete Container in the container's arrow menu.

4. Click Delete Container to confirm the container's removal.
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CHAPTER 5. NETWORKING

OpenStack Networking (neutron) is the software-defined networking component of RHEL
OpenStack Platform. The virtual network infrastructure enables connectivity between
instances and the physical external network.

5.1. MANAGE NETWORK RESOURCES

Add and remove OpenStack Networking resources such as subnets and routers to suit your
RHEL OpenStack Platform deployment.

5.1.1. Add a Network

Create a network to give your instances a place to communicate with each other and receive
IP addresses using DHCP.

A network can also be integrated with external networks in your RHEL OpenStack Platform
deployment or elsewhere, such as the physical network. This integration allows your
instances to communicate with, and be reachable by, outside systems. To integrate your
network with your physical external network, see Section 5.3, “Bridge the physical network” .

When creating networks, it is important to know that networks can host multiple subnets. This
is useful if you intend to host distinctly different systems in the same network, and would
prefer a measure of isolation between them. For example, you can designate that only
webserver traffic is present on one subnet, while database traffic traverse another. Subnets
are isolated from each other, and any instance that wishes to communicate with another
subnet must have their traffic directed by a router. Consider placing systems that will require
a high volume of traffic amongst themselves in the same subnet, so that they don't require
routing, and avoid the subsequent latency and load.

5.1 .1 .1 . Creat e a Net wo rk

1. In the dashboard, select Project > Network > Networks.

2. Click +Create Network.

3. Specify the following:

Field Descript ion
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Netwo rk
Name Descrip tive name, b ased  o n the ro le that the netwo rk wil l p erfo rm. If yo u

are integ rating  the netwo rk with an external VLAN, co nsid er ap p end ing
the VLAN ID numb er to  the name. Examp les:

webservers_122, i f yo u are ho sting  HTTP web  servers in this
sub net, and  yo ur VLAN tag  is  122.

internal-only, i f yo u intend  to  keep  the netwo rk traffic  p rivate,
and  no t integ rate it with an external netwo rk.

Ad min
State

Co ntro ls whether the netwo rk is  immed iately availab le. This field  allo ws
yo u to  create the netwo rk b ut s ti l l  keep  it in a Down s tate, where it is
lo g ically p resent b ut s ti l l  inactive. This is  useful if yo u d o  no t intend  to
enter the netwo rk into  p ro d uctio n rig ht away.

Field Descript ion

4. Click the Next button, and specify the following in the Subnet tab:

Field Descript ion

Create
Sub net

Determines whether a sub net is  created . Fo r examp le, yo u mig ht no t
want to  create a sub net if yo u intend  to  keep  this  netwo rk as a
p laceho ld er witho ut netwo rk co nnectivity.

Sub net
Name

Descrip tive name.

Netwo rk
Ad d ress

Ad d ress in CIDR fo rmat, which co ntains the IP ad d ress rang e and
sub net mask in o ne value. To  d etermine the ad d ress, calculate the
numb er o f b its  masked  in the sub net mask and  ap p end  that value to  the
IP ad d ress rang e. Fo r examp le, the sub net mask 255.255.255.0  has 24
masked  b its . To  use this  mask with the IPv4 ad d ress rang e
19 2.16 8 .122.0 , sp ecify the ad d ress 192.168.122.0/24 .

IP
Vers io n Internet p ro to co l, where valid  typ es are IPv4  o r IPv6 . The IP ad d ress

rang e in the Network Address field  must match whichever vers io n
yo u select.

Gateway
IP

IP ad d ress o f the ro uter interface fo r yo ur d efault g ateway. This ad d ress
is the next ho p  fo r ro uting  any traffic  d estined  fo r an external lo catio n,
and  must b e within the rang e sp ecified  in the Network Address field .
Fo r examp le, if yo ur CIDR netwo rk ad d ress is  19 2.16 8 .122.0 /24, then
yo ur d efault g ateway is  l ikely to  b e 19 2.16 8 .122.1.

Disab le
Gateway

Disab les fo rward ing  and  keep s the netwo rk iso lated .
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5. Click Next to specify DHCP options:

Field Descript ion

Enab le DHCP Enab les DHCP services fo r this  sub net. DHCP allo ws yo u to
auto mate the d istrib utio n o f IP setting s to  yo ur instances.

IPv6  Ad d ress
Co nfig uratio n
Mo d e

If creating  an IPv6  netwo rk, sp ecifies ho w IPv6  ad d resses and
ad d itio nal info rmatio n are allo cated :

No Options Specified  - Select this  o p tio n if IP ad d resses
are set manually, o r a no n Op enStack-aware metho d  is  used  fo r
ad d ress allo catio n.

SLAAC (Stateless Address Autoconfiguration) -
Instances g enerate IPv6  ad d resses b ased  o n Ro uter
Ad vertisement (RA) messag es sent fro m the Op enStack
Netwo rking  ro uter. This co nfig uratio n results  in an Op enStack
Netwo rking  sub net created  with ra_mode set to  slaac and  
address_mode set to  slaac.

DHCPv6 stateful  - Instances receive IPv6  ad d resses as well
as ad d itio nal o p tio ns (fo r examp le, DNS) fro m Op enStack
Netwo rking  DHCPv6  service. This co nfig uratio n results  in a
sub net created  with ra_mode set to  dhcpv6-stateful  and  
address_mode set to  dhcpv6-stateful .

DHCPv6 stateless - Instances g enerate IPv6  ad d resses
b ased  o n Ro uter Ad vertisement (RA) messag es sent fro m the
Op enStack Netwo rking  ro uter. Ad d itio nal o p tio ns (fo r examp le,
DNS) are allo cated  fro m the Op enStack Netwo rking  DHCPv6
service. This co nfig uratio n results  in a sub net created  with 
ra_mode set to  dhcpv6-stateless and  address_mode
set to  dhcpv6-stateless.

Allo catio n
Po o ls Rang e o f IP ad d resses yo u wo uld  l ike DHCP to  assig n. Fo r

examp le, the value 192.168.22.100,192.168.22.100
co nsid ers all 'up '  ad d resses in that rang e as availab le fo r
allo catio n.

DNS Name
Servers IP ad d resses o f the DNS servers availab le o n the netwo rk. DHCP

d istrib utes these ad d resses to  the instances fo r name reso lutio n.

Ho st Ro utes

Static  ho st ro utes. Firs t sp ecify the d estinatio n netwo rk in CIDR
fo rmat, fo llo wed  b y the next ho p  that sho uld  b e used  fo r ro uting .
Fo r examp le: 19 2.16 8 .23.0 /24, 10 .1.31.1

Pro vid e this  value if yo u need  to  d is trib ute static  ro utes to
instances.

6. Click Create.
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The completed network is available for viewing in the Networks tab. You can also click 
Edit to change any options as needed. Now when you create instances, you can configure
them now to use its subnet, and they will subsequently receive any specified DHCP options.

5.1 .1 .2 . Creat e an Advanced Net wo rk

Advanced network options are available for administrators, when creating a network from the
Admin view. These options define the network type to use, and allow tenants to be specified:

1. In the dashboard, select Admin > Networks > Create Network > Project.

2. Select a destination project to host the new network using Project.

3. Review the options in Provider Network Type:

Local  - Traffic remains on the local Compute host and is effectively isolated from
any external networks.

Flat - Traffic remains on a single network and can also be shared with the host.
No VLAN tagging or other network segregation takes place.

VLAN - Create a network using a VLAN ID  that corresponds to a VLAN present in
the physical network. Allows instances to communicate with systems on the same
layer 2 VLAN.

GRE - Use a network overlay that spans multiple nodes for private communication
between instances. Traffic egressing the overlay must be routed.

VXLAN - Use a network overlay that spans multiple nodes for private
communication between instances. Traffic egressing the overlay must be routed.

4. Click Create Network, and review the Project's Network Topology to validate
that the network has been successfully created.

5.1 .1 .3. Add Net wo rk Ro ut ing

To allow traffic to be routed to and from your new network, you must add its subnet as an
interface to an existing virtual router:

1. In the dashboard, select Project > Network > Routers.

2. Click on your virtual router's name in the Routers list, and click +Add Interface.

3. In the Subnet list, select the name of your new subnet.

4. You can optionally specify an IP address for the interface in this field.
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5. Click Add Interface.

Instances on your network are now able to communicate with systems outside the subnet.

5.1.2. Delete a Network

There are occasions where it becomes necessary to delete a network that was previously
created, perhaps as housekeeping or as part of a decommisioning process. In order to
successfully delete a network, you must first remove or detach any interfaces where it is still
in use. The following procedure provides the steps for deleting a network in your project,
together with any dependent interfaces.

1. In the dashboard, select Project > Network > Networks.

2. Remove all router interfaces associated with the target network's subnets. To remove
an interface:

a. Find the ID number of the network you would like to delete by clicking on your
target network in the Networks list, and looking at the its ID field. All the
network's associated subnets will share this value in their Network ID  field.

b. Select Project > Network > Routers, click on your virtual router's
name in the Routers list, and locate the interface attached to the subnet you
would like to delete. You can distinguish it from the others by the IP address
that would have served as the gateway IP. In addition, you can further
validate the distinction by ensuring that the interface's network ID matches
the ID you noted in the previous step.

c. Click the interface's Delete Interface button.

3. Select Project > Network > Networks, and click the name of your network.
Click the target subnet's Delete Subnet button.

Note

If you are still unable to remove the subnet at this point, ensure it is not
already being used by any instances.

4. Select Project > Network > Networks, and select the network you would like to
delete.

5. Click Delete Networks in this and the next dialog screen.

5.1.3. Create a Subnet
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Subnets are the means by which instances are granted network connectivity. Each instance
is assigned to a subnet as part of the instance creation process, therefore it's important to
consider proper placement of instances to best accomodate their connectivity requirements.
Subnets are created in pre-existing networks.

Remember that tenant networks in OpenStack Networking can host multiple subnets. This is
useful if you intend to host distinctly different systems in the same network, and would prefer
a measure of isolation between them. For example, you can designate that only webserver
traffic is present on one subnet, while database traffic traverse another. Subnets are isolated
from each other, and any instance that wishes to communicate with another subnet must
have their traffic directed by a router. Consider placing systems that will require a high
volume of traffic amongst themselves in the same subnet, so that they don't require routing,
and avoid the subsequent latency and load.

Procedure 5.1. Create a new subnet

1. In the dashboard, select Project > Network > Networks, and click your
network's name in the Networks view.

2. Click Create Subnet, and specify the following.

Field Descript ion

Sub net
Name

Descrip tive sub net name.

Netwo rk
Ad d ress

Ad d ress in CIDR fo rmat, which co ntains the IP ad d ress rang e and
sub net mask in o ne value. To  d etermine the ad d ress, calculate the
numb er o f b its  masked  in the sub net mask and  ap p end  that value to  the
IP ad d ress rang e. Fo r examp le, the sub net mask 255.255.255.0  has 24
masked  b its . To  use this  mask with the IPv4 ad d ress rang e
19 2.16 8 .122.0 , sp ecify the ad d ress 192.168.122.0/24 .

IP
Vers io n Internet p ro to co l, where valid  typ es are IPv4  o r IPv6 . The IP ad d ress

rang e in the Network Address field  must match whichever vers io n
yo u select.

Gateway
IP

IP ad d ress o f the ro uter interface fo r yo ur d efault g ateway. This ad d ress
is the next ho p  fo r ro uting  any traffic  d estined  fo r an external lo catio n,
and  must b e within the rang e sp ecified  in the Network Address field .
Fo r examp le, if yo ur CIDR netwo rk ad d ress is  19 2.16 8 .122.0 /24, then
yo ur d efault g ateway is  l ikely to  b e 19 2.16 8 .122.1.

Disab le
Gateway

Disab les fo rward ing  and  keep s the netwo rk iso lated .

3. Click Next to specify DHCP options:
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Field Descript ion

Enab le DHCP Enab les DHCP services fo r this  sub net. DHCP allo ws yo u to
auto mate the d istrib utio n o f IP setting s to  yo ur instances.

IPv6  Ad d ress
Co nfig uratio n
Mo d e

If creating  an IPv6  netwo rk, sp ecifies ho w IPv6  ad d resses and
ad d itio nal info rmatio n are allo cated :

No Options Specified  - Select this  o p tio n if IP ad d resses
are set manually, o r a no n Op enStack-aware metho d  is  used  fo r
ad d ress allo catio n.

SLAAC (Stateless Address Autoconfiguration) -
Instances g enerate IPv6  ad d resses b ased  o n Ro uter
Ad vertisement (RA) messag es sent fro m the Op enStack
Netwo rking  ro uter. This co nfig uratio n results  in a Op enStack
Netwo rking  sub net created  with ra_mode set to  slaac and  
address_mode set to  slaac.

DHCPv6 stateful  - Instances receive IPv6  ad d resses as well
as ad d itio nal o p tio ns (fo r examp le, DNS) fro m Op enStack
Netwo rking  DHCPv6  service. This co nfig uratio n results  in a
sub net created  with ra_mode set to  dhcpv6-stateful  and  
address_mode set to  dhcpv6-stateful .

DHCPv6 stateless - Instances g enerate IPv6  ad d resses
b ased  o n Ro uter Ad vertisement (RA) messag es sent fro m the
Op enStack Netwo rking  ro uter. Ad d itio nal o p tio ns (fo r examp le,
DNS) are allo cated  fro m the Op enStack Netwo rking  DHCPv6
service. This co nfig uratio n results  in a sub net created  with 
ra_mode set to  dhcpv6-stateless and  address_mode
set to  dhcpv6-stateless.

Allo catio n
Po o ls Rang e o f IP ad d resses yo u wo uld  l ike DHCP to  assig n. Fo r

examp le, the value 192.168.22.100,192.168.22.100
co nsid ers all 'up '  ad d resses in that rang e as availab le fo r
allo catio n.

DNS Name
Servers IP ad d resses o f the DNS servers availab le o n the netwo rk. DHCP

d istrib utes these ad d resses to  the instances fo r name reso lutio n.

Ho st Ro utes

Static  ho st ro utes. Firs t sp ecify the d estinatio n netwo rk in CIDR
fo rmat, fo llo wed  b y the next ho p  that sho uld  b e used  fo r ro uting .
Fo r examp le: 19 2.16 8 .23.0 /24, 10 .1.31.1

Pro vid e this  value if yo u need  to  d is trib ute static  ro utes to
instances.

4. Click Create.

The new subnet is available for viewing in your network's Subnets list. You can also click 
Edit to change any options as needed. When you create instances, you can configure them
now to use this subnet, and they will subsequently receive any specified DHCP options.
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5.1.4 . Delete a Subnet

You can delete a subnet if it is no longer in use. However, if any instances are still configured
to use the subnet, the deletion attempt fails and the dashboard displays an error message.

This procedure demonstrates how to delete a specific subnet in a network:

1. In the dashboard, select Project > Network > Networks, and click the name of
your network.

2. Select the target subnet and click Delete Subnets.

5.1.5. Add a router

OpenStack Networking provides routing services using an SDN-based virtual router.
Routers are a requirement for your instances to communicate with external subnets,
including those out in the physical network. Routers and subnets connect using 
interfaces, with each subnet requiring its own interface to the router.

A router's default gateway defines the next hop for any traffic received by the router. Its
network is typically configured to route traffic to the external physical network using a virtual
bridge.

1. In the dashboard, select Project > Network > Routers, and click +Create 
Router.

2. Enter a descriptive name for the new router, and click Create router.

3. Click Set Gateway next to the new router's entry in the Routers list.

4. In the External Network list, specify the network that will receive traffic destined for
an external location.

5. Click Set Gateway.

After adding a router, the next step is to configure any subnets you have created to send
traffic using this router. You do this by creating interfaces between the subnet and the router
(see Procedure 5.0, “ ” ).

5.1.6. Delete a router

You can delete a router if it has no connected interfaces. This procedure describes the steps
needed to first remove a router's interfaces, and then the router itself.
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1. In the dashboard, select Project > Network > Routers, and click on the name
of the router you would like to delete.

2. Select the interfaces of type Internal Interface.

3. Click Delete Interfaces.

4. From the Routers list, select the target router and click Delete Routers.

5.1.7. Add an interface

Interfaces allow you to interconnect routers with subnets. As a result, the router can direct
any traffic that instances send to destinations outside of their intermediate subnet. This
procedure adds a router interface and connects it to a subnet.

The procedure uses the Network Topology feature, which displays a graphical
representation of all your virtual router and networks and enables you to perform network
management tasks.

1. In the dashboard, select Project > Network > Network Topology.

2. Locate the router you wish to manage, hover your mouse over it, and click Add 
Interface.

3. Specify the Subnet to which you would like to connect the router.

4. You have the option of specifying an IP Address. The address is useful for testing
and troubleshooting purposes, since a successful ping to this interface indicates
that the traffic is routing as expected.

5. Click Add interface.

The Network Topology diagram automatically updates to reflect the new interface
connection between the router and subnet.

5.1.8. Delete an interface

You can remove an interface to a subnet if you no longer require the router to direct its traffic.
This procedure demonstrates the steps required for deleting an interface:

1. In the dashboard, select Project > Network > Routers.

2. Click on the name of the router that hosts the interface you would like to delete.

3. Select the interface (will be of type Internal Interface), and click Delete 
Interfaces.
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5.2. CONFIGURE IP ADDRESSING

You can use procedures in this section to manage your IP address allocation in OpenStack
Networking.

5.2.1. Create Float ing IP Pools

Floating IP addresses allow you to direct ingress network traffic to your OpenStack
instances. You begin by defining a pool of validly routable external IP addresses, which can
then be dynamically assigned to an instance. OpenStack Networking then knows to route all
incoming traffic destined for that floating IP to the instance to which it has been assigned.

Note

OpenStack Networking allocates floating IP addresses to all projects (tenants) from
the same IP ranges/CIDRs. Meaning that every subnet of floating IPs is
consumable by any and all projects. You can manage this behavior using quotas
for specific projects. For example, you can set the default to 10  for ProjectA and 
ProjectB, while setting ProjectC's quota to 0 .

The Floating IP allocation pool is defined when you create an external subnet. If the subnet
only hosts floating IP addresses, consider disabling DHCP allocation with the 
enable_dhcp=Falseoption:

# neutron subnet-create --name SUBNET_NAME --enable_dhcp=False --
allocation_pool start=IP_ADDRESS,end=IP_ADDRESS --
gateway=IP_ADDRESS NETWORK_NAME CIDR

Example 5.1. 

# neutron subnet-create --name public_subnet --enable_dhcp=False 
--allocation_pool start=192.168.100.20,end=192.168.100.100 --
gateway=192.168.100.1 public 192.168.100.0/24

5.2.2. Assign a Specific Float ing IP

You can assign a specific floating IP address to an instance using the nova command (or
through the dashboard; see Section 3.1.2, “Update an Instance (Actions menu)” ).

# nova add-floating-ip INSTANCE_NAME IP_ADDRESS

Example 5.2. 

In this example, a floating IP address is allocated to an instance named corp-vm-01:
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# nova add-floating-ip corp-vm-01 192.168.100.20

5.2.3. Assign a Random Float ing IP

Floating IP addresses can be dynamically allocated to instances. You do not select a
particular IP address, but instead request that OpenStack Networking allocates one from the
pool.

1. Allocate a floating IP from the previously created pool:

# neutron floatingip-create public
+---------------------+--------------------------------------
+
| Field               | Value                                
|
+---------------------+--------------------------------------
+
| fixed_ip_address    |                                      |
| floating_ip_address | 192.168.100.20                       |
| floating_network_id | 7a03e6bc-234d-402b-9fb2-0af06c85a8a3 |
| id                  | 9d7e2603482d                         
|
| port_id             |                                      
|
| router_id           |                                      
|
| status              | ACTIVE                               
|
| tenant_id           | 9e67d44eab334f07bf82fa1b17d824b6     |
+---------------------+--------------------------------------
+

2. With the IP address allocated, you can assign it to a particular instance. Locate the
ID of the port associated with your instance (this will match the fixed IP address
allocated to the instance). This port ID is used in the following step to associate the
instance's port ID with the floating IP address ID. You can further distinguish the
correct port ID by ensuring the MAC address in the third column matches the one on
the instance.

# neutron port-list
+--------+------+-------------+------------------------------
--------------------------+
| id     | name | mac_address | fixed_ips                                              
|
+--------+------+-------------+------------------------------
--------------------------+
| ce8320 |      | 3e:37:09:4b | {"subnet_id": "361f27", 
"ip_address": "192.168.100.2"} |
| d88926 |      | 3e:1d:ea:31 | {"subnet_id": "361f27", 
"ip_address": "192.168.100.5"} |
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| 8190ab |      | 3e:a3:3d:2f | {"subnet_id": "b74dbb", 
"ip_address": "10.10.1.25"}|
+--------+------+-------------+------------------------------
--------------------------+

3. Use the neutron command to associate the floating IP address with the desired port
ID of an instance:

# neutron floatingip-associate 9d7e2603482d 8190ab

5.2.4 . Create Mult iple Float ing IP Pools

OpenStack Networking supports one floating IP pool per L3 agent. Therefore, scaling out
your L3 agents allows you to create additional floating IP pools.

Note

Ensure that handle_internal_only_routers in 
/etc/neutron/neutron.conf is configured to True for only one L3 agent in
your environment. This option configures the L3 agent to manage only non-
external routers.

5.3. BRIDGE THE PHYSICAL NETWORK

The procedure below enables you to bridge your virtual network to the physical network to
enable connectivity to and from virtual instances. In this procedure, the example physical 
eth0  interface is mapped to the br-ex bridge; the virtual bridge acts as the intermediary
between the physical network and any virtual networks. As a result, all traffic traversing eth0
uses the configured Open vSwitch to reach instances.

1. Map a physical NIC to the virtual Open vSwitch bridge:

# vi /etc/sysconfig/network-scripts/ifcfg-eth0
DEVICE=eth0
TYPE=OVSPort
DEVICETYPE=ovs
OVS_BRIDGE=br-ex
ONBOOT=yes

2. Configure the virtual bridge with the IP address details that were previously allocated
to eth0:

# vi /etc/sysconfig/network-scripts/ifcfg-br-ex
DEVICE=br-ex
DEVICETYPE=ovs
TYPE=OVSBridge
BOOTPROTO=static
IPADDR=192.168.120.10
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NETMASK=255.255.255.0
GATEWAY=192.168.120.1
DNS1=192.168.120.1
ONBOOT=yes

Where IPADDR , NETMASK GATEWAY , and DNS1 (name server) must be updated to
match your network.

You can now assign floating IP addresses to instances and make them available to the
physical network.
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CHAPTER 6. CLOUD RESOURCES

This chapter discusses how to configure stacks and monitor cloud resources in RHEL
OpenStack Platform.

6.1. MANAGE STACKS

The Orchestration service provides a framework through which you can define an instance's
resource parameters (for example, floating IPs, volumes, or security groups) and properties
(for example, key pairs, image to be used, or flavor) using Heat templates. These templates
use a human-readable syntax and can be defined in text files (thereby allowing users to
check them into version control). Templates allow you to easily deploy and re-configure
infrastructure for applications within the OpenStack cloud.

Instances deployed using Heat templates through the Orchestration service are known as
stacks. The dashboard allows you to launch, delete, and update stacks from Heat templates.
You can input a Heat template directly into the dashboard, or use text files from your local file
system or HTTP URL.

6.1.1. Download Sample Heat  T emplates

Red Hat Enterprise Linux OpenStack Platform includes sample templates you can use to test
and study Heat's core functionality. To use these templates, install the openstack-heat-
templates package:

# yum install openstack-heat-templates

This package installs the sample Heat templates in /usr/share/openstack-heat-
templates/software-config/example-templates.

6.1.2. Launch a Stack

1. In the dashboard, select Project > Orchestration > Stacks, and click 
Launch Stack.

2. Select an option from the Template Source list:

Opt ion Descript ion

File

Use a lo cal temp late fi le o n yo ur system. Select yo ur fi le b y c licking  
Template File > Browse.

Direct
Inp ut Enter yo ur temp late d irectly into  the d ashb o ard  using  the Template 

Data field .
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URL

Use an external HTTP URL fo r the temp late. Sp ecify the temp late's  URL
in the Template URL field .

Opt ion Descript ion

Note

Red Hat Enterprise Linux OpenStack Platform includes sample templates.
For more details, see Section 6.1.1, “Download Sample Heat Templates” .

3. Select an option from the Environment Source list:

Opt ion Descript ion

File

Use a .yaml  fi le fo r the enviro nment. Select yo ur enviro nment b y
clicking  Environment File > Browse.

Direct
Inp ut Enter yo ur enviro nment d ata d irectly into  the d ashb o ard  using  the 

Environment Data field .

4. Click Next.

5. Specify values for the following fields:

Field Descript ion

Stack Name Name to  id entify the stack.

Creatio n
Timeo ut
(minutes)

Numb er o f minutes b efo re d eclaring  a timeo ut o n the stack launch.

Ro llb ack On
Failure

If selected , ro lls  b ack any chang es o r up d ates to  the temp late if the
stack launch fails .

Passwo rd  fo r
user
USERNAME

Temp o rary p asswo rd  fo r the user launching  the stack.

The Launch Stack  window may also contain other fields, depending on the
parameters defined in the template. Update these fields as required.

6. Click Launch.
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6. Click Launch.

6.1.3. Update a Stack

1. If stack components need to be updated, edit your original template.

2. In the dashboard, select Project > Orchestration > Stacks.

3. Select the stack's Change Stack Template action.

4. Select an option from the Template Source list:

Opt ion Descript ion

File

Use a lo cal temp late fi le o n yo ur system. Select yo ur fi le b y c licking  
Template File > Browse.

Direct
Inp ut Enter yo ur temp late d irectly into  the d ashb o ard  using  the Template 

Data field .

URL

Use an external HTTP URL fo r the temp late. Sp ecify the temp late's  URL
in the Template URL field .

5. Select an option from the Environment Source list:

Opt ion Descript ion

File

Use a .yaml  fi le fo r the enviro nment. Select yo ur enviro nment b y
clicking  Environment File > Browse.

Direct
Inp ut Enter yo ur enviro nment d ata d irectly into  the d ashb o ard  using  the 

Environment Data field .

6. Click Next.

7. Specify values for the following fields:
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Field Descript ion

Creatio n
Timeo ut
(minutes)

Numb er o f minutes b efo re d eclaring  a timeo ut o n the stack launch.

Ro llb ack On
Failure

If selected , ro lls  b ack any chang es o r up d ates to  the temp late if the
stack launch fails .

Passwo rd  fo r
user
USERNAME

Temp o rary p asswo rd  fo r the user launching  the stack.

The Launch Stack  window may also contain other fields, depending on the
parameters defined in the template. Update these fields as required.

8. Click Update. The Orchestration service re-launches the stack with the updated
parameters. The Updated  column on the Stacks table now reflects how long it has
been since the stack was last updated.

6.1.4 . Delete a Stack

You can delete a stack through the Stacks table:

1. In the dashboard, select Project > Orchestration > Stacks.

2. Select Delete Stack from the Actions column of a stack.

Note

Alternatively, you can delete multiple stacks simultaneously by selecting
their respective checkboxes and clicking Delete Stacks.

6.2. USING THE TELEMETRY SERVICE

For help with the ceilometer command, use:

# ceilometer help

For help with the subcommands, use:

# ceilometer help subcommand

6.2.1. View Exist ing Alarms

To list configured Telemetry alarms, use:
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# ceilometer alarm-list

To list configured meters for a resource, use:

# ceilometer meter-list --query resource=UUID
+--------------------------+------------+-----------+-----------+--
--------+----------+
| Name                     | Type       | Unit      | Resource  | 
User ID  | Project  | 
+--------------------------+------------+-----------+-----------+--
--------+----------+
| cpu                      | cumulative | ns        | 5056eda...| 
b0e500...| f23524...|
| cpu_util                 | gauge      | %         | 5056eda...| 
b0e500...| f23524...|
| disk.ephemeral.size      | gauge      | GB        | 5056eda...| 
b0e500...| f23524...|
| disk.read.bytes          | cumulative | B         | 5056eda...| 
b0e500...| f23524...|
                      output omitted
| instance                 | gauge      | instance  | 5056eda...| 
b0e500...| f23524...|
| instance:m1.tiny         | gauge      | instance  | 5056eda...| 
b0e500...| f23524...|
| memory                   | gauge      | MB        | 5056eda...| 
b0e500...| f23524...|
| vcpus                    | gauge      | vcpu      | 5056eda...| 
b0e500...| f23524...|
+--------------------------+------------+-----------+--------------
-------------------+

Where UUID is the resource ID for an existing resource (for example, an instance, image, or
volume).

6.2.2. Configure an Alarm

To configure an alarm to activate when a threshold value is crossed, use the ceilometer 
alarm-threshold-create command with the following syntax:

# ceilometer alarm-threshold-create --name alarm-name [--
description alarm-text] --meter-name meter-name --threshold value

Example 6 .1. 

To configure an alarm that activates when the average CPU utilization for an individual
instance exceeds 50% for three consecutive 600s (10 minute) periods, use:

# ceilometer alarm-threshold-create --name cpu_high --description 
'CPU usage high' --meter-name cpu_usage_high --threshold 50 --
comparison-operator gt --statistic avg --period 600 --evaluation-
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periods 3 --alarm-action 'log://' --query resource_id=5056eda6-
8a24-4f52-9cc4-c3ddb6fb4a69

In this example, the notification action is a log message.

To edit an existing threshold alarm, use the ceilometer alarm-threshold-update
command together with the alarm ID, followed by one or more options to be updated.

Example 6 .2. 

To increase the alarm threshold to 75%, use:

# ceilometer alarm-threshold-update 35addb25-d488-4a74-a038-
076aad3a3dc3 --threshold=75

6.2.3. Disable or Delete an Alarm

To disable an alarm, use:

# ceilometer alarm-threshold-update --enabled False ALARM_ID

To delete an alarm, use:

# ceilometer alarm-delete ALARM_ID

6.2.4 . View Samples

To list all the samples for a particular meter name, use:

# ceilometer sample-list --meter METER_NAME

To list samples only for a particular resource within a range of time stamps, use:

# ceilometer sample-list --meter METER_NAME --query 
'resource_id=INSTANCE_ID;timestamp>START_TIME;timestamp>=END_TIME'

Where START_TIME and END_TIME are in the form iso-dateThh:mm:ss.

Example 6 .3. 

To query an instance for samples taken between 13:10:00  and 14:25:00 , use:

#ceilometer sample-list --meter cpu --query 
'resource_id=5056eda6-8a24-4f52-9cc4-c3ddb6fb4a69;timestamp>2015-
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01-12T13:10:00;timestamp>=2015-01-12T14:25:00'
+-------------------+------+------------+---------------+------+-
--------------------+
| Resource ID       | Name | Type       | Volume        | Unit | 
Timestamp           |
+-------------------+------+------------+---------------+------+-
--------------------+
| 5056eda6-8a24-... | cpu  | cumulative | 3.5569e+11    | ns   | 
2015-01-12T14:21:44 |
| 5056eda6-8a24-... | cpu  | cumulative | 3.0041e+11    | ns   | 
2015-01-12T14:11:45 |
| 5056eda6-8a24-... | cpu  | cumulative | 2.4811e+11    | ns   | 
2015-01-12T14:01:54 |
| 5056eda6-8a24-... | cpu  | cumulative | 1.3743e+11    | ns   | 
2015-01-12T13:30:54 |
| 5056eda6-8a24-... | cpu  | cumulative | 84710000000.0 | ns   | 
2015-01-12T13:20:54 |
| 5056eda6-8a24-... | cpu  | cumulative | 31170000000.0 | ns   | 
2015-01-12T13:10:54 |
+-------------------+------+------------+---------------+------+-
--------------------+

6.2.5. Create a Sample

Samples can be created for sending to the Telemetry service and they need not correspond
to a previously defined meter. Use the following syntax:

# ceilometer sample-create --resource_id RESOURCE_ID --meter-name 
METER_NAME --meter-type METER_TYPE --meter-unit METER_UNIT --
sample-volume SAMPLE_VOLUME

Where METER_TYPE can be one of:

Cumulative - a running total

Delta - a change or difference over time

Gauge- a discrete value

Example 6 .4 . 

# ceilometer sample-create -r 5056eda6-8a24-4f52-9cc4-
c3ddb6fb4a69 -m On_Time_Mins --meter-type cumulative --meter-unit 
mins --sample-volume 0
+-------------------+--------------------------------------------
+
| Property          | Value                                      
|
+-------------------+--------------------------------------------
+
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| message_id        | 521f138a-9a84-11e4-8058-525400ee874f       |
| name              | On_Time_Mins                               
|
| project_id        | f2352499957d4760a00cebd26c910c0f           
|
| resource_id       | 5056eda6-8a24-4f52-9cc4-c3ddb6fb4a69       
|
| resource_metadata | {}                                         
|
| source            | f2352499957d4760a00cebd26c910c0f:openstack |
| timestamp         | 2015-01-12T17:56:23.179729                 |
| type              | cumulative                                 
|
| unit              | mins                                       
|
| user_id           | b0e5000684a142bd89c4af54381d3722           
|
| volume            | 0.0                                        
|
+-------------------+--------------------------------------------
+

Where volume, normally the value obtained as a result of the sampling action, is in this
case the value being created by the command.

Note

Samples are not updated because the moment a sample is created, it is sent to the
Telemetry service. Samples are essentially messages, which is why they have a
message ID. To create new samples, repeat the sample-create command and
update the --sample-volume value.

6.2.6. View Cloud Usage Stat ist ics

OpenStack administrators can use the dashboard to view cloud statistics.

1. As an admin user in the dashboard, select Admin > System > Resource 
Usage.

2. Click one of the following:

Daily Report — View a report of daily usage per project. Select the date range
and a limit for the number of projects, and click Generate Report; the daily
usage report is displayed.

Stats — View a graph of metrics grouped by project. Select the values and time
period using the drop-down menus; the displayed graph is automatically
updated.

The ceilometer command line client can also be used for viewing cloud usage statics.
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Example 6 .5. 

To view all the statistics for the cpu_util  meter, use:

# ceilometer statistics --meter cpu_util
+--------+----------------+---------------+-----+-----+------+---
----+------+--------
| Period | Period Start   |Period End     | Max | Min | Avg  | 
Sum   | Count| Dura...
+--------+----------------+---------------+-----+-----+------+---
----+------+--------
| 0      | 2015-01-09T14: |2015-01-09T14:2| 9.44| 0.0 | 6.75 | 
337.94| 50   | 2792...
+--------+----------------+---------------+-----+-----+------+---
----+------+--------

Example 6 .6 . 

Statistics can be restricted to a specific resource by means of the --query option, and
restricted to a specific range by means of the timestamp option.

# ceilometer statistics --meter cpu_util --query 
'resource_id=5056eda6-8a24-4f52-9cc4-c3ddb6fb4a69;timestamp>2015-
01-12T13:00:00;timestamp<=2015-01-13T14:00:00'
+--------+----------------+---------------+-----+-----+------+---
----+------+--------
| Period | Period Start   |Period End     | Max | Min | Avg  | 
Sum   | Count| Dura...
+--------+----------------+---------------+-----+-----+------+---
----+------+--------
| 0      | 2015-01-12T20:1|2015-01-12T20:1| 9.44| 5.95| 8.90 | 
347.10| 39   | 2465...
+--------+----------------+---------------+-----+-----+------+---
----+------+--------
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CHAPTER 7. TROUBLESHOOTING

This chapter contains logging and support information to assist with troubleshooting your
RHEL OpenStack Platform deployment.

7.1. LOGGING

RHEL OpenStack Platform writes informational messages to specific log files; you can use
these messages for troubleshooting and monitoring system events.

7.1.1. Log Files for OpenStack Services

Each OpenStack component has a separate logging directory containing files specific to a
running service.

Table 7.1. Block Storage (cinder)  log  f iles

Service Service Name Log Pat h

Blo ck Sto rag e API o p enstack-c ind er-ap i.service /var/lo g /c ind er/ap i.lo g

Blo ck Sto rag e Backup o p enstack-c ind er-b ackup .service /var/lo g /c ind er/b ackup .lo
g

Info rmatio nal messag es The c ind er-manag e co mmand /var/lo g /c ind er/c ind er-
manag e.lo g

Blo ck Sto rag e Sched uler o p enstack-c ind er-sched uler.service /var/lo g /c ind er/sched uler.
lo g

Blo ck Sto rag e Vo lume o p enstack-c ind er-vo lume.service /var/lo g /c ind er/vo lume.lo
g

Table 7.2. Compute (nova)  log f iles

Service Service Name Log Pat h

Op enStack Co mp ute API service o p enstack-no va-
ap i.service

/var/lo g /no va/no va-
ap i.lo g
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Op enStack Co mp ute certificate
server

o p enstack-no va-
cert.service

/var/lo g /no va/no va-
cert.lo g

Op enStack Co mp ute service o p enstack-no va-
co mp ute.service

/var/lo g /no va/no va-
co mp ute.lo g

Op enStack Co mp ute Co nd ucto r
service

o p enstack-no va-
co nd ucto r.service

/var/lo g /no va/no va-
co nd ucto r.lo g

Op enStack Co mp ute VNC co nso le
authenticatio n server

o p enstack-no va-
co nso leauth.service

/var/lo g /no va/no va-
co nso leauth.lo g

Info rmatio nal messag es nova-manage
co mmand

/var/lo g /no va/no va-
manag e.lo g

Op enStack Co mp ute No VNC Pro xy
service

o p enstack-no va-
no vncp ro xy.service

/var/lo g /no va/no va-
no vncp ro xy.lo g

Op enStack Co mp ute Sched uler
service

o p enstack-no va-
sched uler.service

/var/lo g /no va/no va-
sched uler.lo g

Service Service Name Log Pat h

Table 7.3. Dashboard (horiz on)  log f iles

Service Service Name Log Pat h

Lo g  o f certain user interactio ns Dashb o ard  interface /var/lo g /ho rizo n/ho rizo n.l
o g

Table 7.4 . Ident ity Service (keystone)  log f iles

Service Service Name Log Pat h

Op enStack Id entity Service o p enstack-
keysto ne.service

/var/lo g /keysto ne/keysto n
e.lo g

Table 7.5. Image Service (g lance)  log f iles
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Service Service Name Log Pat h

Op enStack Imag e Service API
server

o p enstack-g lance-
ap i.service

/var/lo g /g lance/ap i.lo g

Op enStack Imag e Service Reg istry
server

o p enstack-g lance-
reg istry.service

/var/lo g /g lance/reg istry.lo
g

Table 7.6 . OpenStack Networking (neutron)  log f iles

Service Service Name Log Pat h

Op enStack Netwo rking  Layer 3
Ag ent

neutro n-l3-ag ent.service /var/lo g /neutro n/l3-
ag ent.lo g

Op en vSwitch ag ent neutro n-o p envswitch-
ag ent.service

/var/lo g /neutro n/o p envswi
tch-ag ent.lo g

Metad ata ag ent service neutro n-metad ata-
ag ent.service

/var/lo g /neutro n/metad ata
-ag ent.lo g

Op enStack Netwo rking  service neutro n-server.service /var/lo g /neutro n/server.lo
g

Table 7.7. Telemetry (ceilometer)  log  f iles

Service Service Name Log Pat h

Op enStack ceilo meter
no tificatio n ag ent

o p enstack-ceilo meter-
no tificatio n.service

/var/lo g /ceilo meter/ag ent-
no tificatio n.lo g

Op enStack ceilo meter
alarm evaluatio n

o p enstack-ceilo meter-alarm-
evaluato r.service

/var/lo g /ceilo meter/alarm-
evaluato r.lo g

Op enStack ceilo meter
alarm no tificatio n

o p enstack-ceilo meter-alarm-
no tifier.service

/var/lo g /ceilo meter/alarm-
no tifier.lo g
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Op enStack ceilo meter
API

o p enstack-ceilo meter-ap i.service /var/lo g /ceilo meter/ap i.lo
g

Info rmatio nal messag es Mo ng o DB integ ratio n /var/lo g /ceilo meter/ceilo
meter-d b sync.lo g

Op enStack ceilo meter
central ag ent

o p enstack-ceilo meter-
central.service

/var/lo g /ceilo meter/centra
l.lo g

Op enStack ceilo meter
co llectio n

o p enstack-ceilo meter-
co llecto r.service

/var/lo g /ceilo meter/co llec
to r.lo g

Op enStack ceilo meter
co mp ute ag ent

o p enstack-ceilo meter-
co mp ute.service

/var/lo g /ceilo meter/co mp
ute.lo g

Service Service Name Log Pat h

Table 7.8. Orchest rat ion (heat )  log  f iles

Service Service Name Log Pat h

Op enStack Heat API Service o p enstack-heat-
ap i.service

/var/lo g /heat/heat-ap i.lo g

Op enstack Heat Eng ine Service o p enstack-heat-
eng ine.service

/var/lo g /heat/heat-
eng ine.lo g

Orchestratio n service events n/a /var/lo g /heat/heat-
manag e.lo g

7.1.2. Configure logging opt ions

Each component maintains its own separate logging configuration in its respective
configuration file. For example, in Compute, these options are set in 
/etc/nova/nova.conf:

Increase the level of informational logging by enabling debugging. This option greatly
increases the amount of information captured, so you may want to consider using it only
temporarily, or first reviewing your log rotation settings.
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debug=True

Enable verbose logging:

verbose=True

Change the log file path:

log_dir=/var/log/nova

Send your logs to a central syslog server:

use_syslog=True
syslog_log_facility=LOG_USER

Note

Options are also available for timestamp configuration and log formatting, among
others. Review the component's configuration file for additional logging options.

7.2. SUPPORT

If client commands fail or you run into other issues, please contact Red Hat Technical
Support with a description of what happened, an sosreport, the full console output, and
all log files referenced in the console output.

For information about the sosreport command (sos package), refer to What is a sosreport
and how to create one in Red Hat Enterprise Linux 4.6 and later.
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APPENDIX A. IMAGE CONFIGURATION PARAMETERS

The following keys can be used with the property option for both the glance image-
update and glance image-create commands.

Example A.1. 

$ glance image-update IMG-UUID --property architecture=x86_64

Note

Behavior set using image properties overrides behavior set using flavors. For more
information, see Section 3.3, “Manage Flavors” .

Table A.1. Property keys

Specific
t o

Key Descript ion Support ed values

All architect
ure

The CPU architecture that must
b e sup p o rted  b y the hyp erviso r.
Fo r examp le, x86_64 , arm, o r 
ppc64 . Run uname -m to  g et
the architecture o f a machine. We
stro ng ly reco mmend  using  the
architecture d ata vo cab ulary
d efined  b y the l ib o sinfo  p ro ject
fo r this  p urp o se.

alpha-DEC 6 4-b it RISC

armv7l -ARM Co rtex-A7
MPCo re

cris-Ethernet, To ken Ring ,
AXis-Co d e Red uced
Instructio n Set

i686 -Intel s ixth-g eneratio n
x8 6  (P6  micro  architecture)

ia64 -Itanium

lm32-Lattice Micro 32

m68k-Mo to ro la 6 8 0 0 0

microblaze-Xil inx 32-b it
FPGA (Big  End ian)

microblazeel -Xil inx 32-b it
FPGA (Little End ian)

mips-MIPS 32-b it RISC (Big
End ian)
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mipsel -MIPS 32-b it RISC
(Little End ian)

mips64 -MIPS 6 4-b it RISC
(Big  End ian)

mips64el -MIPS 6 4-b it RISC
(Little End ian)

openrisc-Op enCo res RISC

parisc-HP Precis io n
Architecture RISC

parisc64 -HP Precis io n
Architecture 6 4-b it RISC

ppc-Po werPC 32-b it

ppc64 -Po werPC 6 4-b it

ppcemb-Po werPC
(Emb ed d ed  32-b it)

s390 -IBM Enterp rise Systems
Architecture/39 0

s390x-S/39 0  6 4-b it

sh4 -Sup erH SH-4 (Little
End ian)

sh4eb-Sup erH SH-4 (Big
End ian)

sparc-Scalab le Pro cesso r
Architecture, 32-b it

sparc64 -Scalab le Pro cesso r
Architecture, 6 4-b it

unicore32-Micro p ro cesso r
Research and  Develo p ment
Center RISC Unico re32

x86_64 -6 4-b it extensio n o f
IA-32

xtensa-Tensil ica Xtensa
co nfig urab le micro p ro cesso r
co re

Specific
t o

Key Descript ion Support ed values
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xtensaeb-Tensil ica Xtensa
co nfig urab le micro p ro cesso r
co re (Big  End ian)

Not e

The architecture
o p tio ns fully sup p o rted
b y Red  Hat are i686
and  x86_64 .

All hyp ervis
o r_typ e

The hyp erviso r typ e. kvm, vmware

All instance
_uuid

Fo r snap sho t imag es, this  is  the
UUID o f the server used  to  create
this imag e.

Valid  server UUID

All kernel_i
d

The ID o f an imag e sto red  in the
Imag e Service that sho uld  b e
used  as the kernel when b o o ting
an AMI-style imag e.

Valid  imag e ID

All o s_d istr
o

The co mmo n name o f the
o p erating  system d istrib utio n in
lo wercase (uses the same d ata
vo cab ulary as the l ib o sinfo
p ro ject). Sp ecify o nly a
reco g nized  value fo r this  field .
Dep recated  values are l is ted  to
assist yo u in searching  fo r the
reco g nized  value.

arch-Arch Linux. Do  no t use 
archlinux o r 
org.archlinux

centos-Co mmunity
Enterp rise Op erating  System.
Do  no t use org.centos o r 
CentOS

debian-Deb ian. Do  no t use 
Debian o r org.debian

fedora-Fed o ra. Do  no t use 
Fedora, org.fedora, o r 
org.fedoraproject

freebsd -FreeBSD. Do  no t
use org.freebsd , 
freeBSD , o r FreeBSD

gentoo -Gento o  Linux. Do
no t use Gentoo  o r 
org.gentoo

mandrake-Mand rakelinux
(Mand rakeSo ft) d is trib utio n.
Do  no t use mandrakelinux
o r MandrakeLinux

Specific
t o

Key Descript ion Support ed values
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mandriva-Mand riva Linux.
Do  no t use mandrivalinux

mes-Mand riva Enterp rise
Server. Do  no t use 
mandrivaent o r 
mandrivaES

msdos-Micro so ft Disc
Op erating  System. Do  no t use
ms-dos

netbsd -NetBSD. Do  no t use 
NetBSD  o r org.netbsd

netware-No vell NetWare. Do
no t use novell  o r NetWare

openbsd -Op enBSD. Do  no t
use OpenBSD  o r 
org.openbsd

opensolaris-Op enSo laris .
Do  no t use OpenSolaris o r
org.opensolaris

opensuse-o p enSUSE. Do
no t use suse, SuSE, o r 
org.opensuse

rhel -Red  Hat Enterp rise
Linux. Do  no t use redhat, 
RedHat, o r com.redhat

sled -SUSE Linux Enterp rise
Deskto p . Do  no t use 
com.suse

ubuntu-Ub untu. Do  no t use 
Ubuntu, com.ubuntu, 
org.ubuntu, o r 
canonical

windows-Micro so ft
Wind o ws. Do  no t use 
com.microsoft.server

All o s_vers i
o n

The o p erating  system vers io n as
sp ecified  b y the d istrib uto r.

Vers io n numb er (fo r examp le,
" 11.10 " )

Specific
t o

Key Descript ion Support ed values
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All ramd isk
_id

The ID o f imag e sto red  in the
Imag e Service that sho uld  b e
used  as the ramd isk when
b o o ting  an AMI-style imag e.

Valid  imag e ID

All vm_mo d
e

The virtual machine mo d e. This
rep resents the ho st/g uest ABI
(ap p licatio n b inary interface)
used  fo r the virtual machine.

hvm-Fully virtualized . This is  the
mo d e used  b y QEMU and  KVM.

lib virt
API
d river

hw_d isk
_b us

Sp ecifies the typ e o f d isk
co ntro ller to  attach d isk d evices
to .

scsi , virtio , ide, o r usb.

l ib virt
API
d river

hw_num
a_no d e
s

Numb er o f NUMA no d es to
exp o se to  the instance (d o es no t
o verrid e flavo r d efinitio n).

Integ er. Fo r a d etailed  examp le
o f NUMA-to p o lo g y d efinitio n,
refer to  the hw:NUMA_def key in
Sectio n 3.3.4.2, “ Ad d  Metad ata” .

l ib virt
API
d river

hw_num
a_memp
o licy

NUMA memo ry allo catio n p o licy
(d o es no t o verrid e flavo r
d efinitio n).

stric t - Mand ato ry fo r the
instance's RAM allo catio ns to
co me fro m the NUMA no d es
to  which it is  b o und  (d efault if
numa_no d es is  sp ecified ).

p referred  - The kernel can fall
b ack to  using  an alternative
no d e. Useful when the
'hw:numa_no d es'  p arameter is
set to  '1' .

l ib virt
API
d river

hw_num
a_cp us.
0

Map p ing  o f vCPUs N-M to  NUMA
no d e 0  (d o es no t o verrid e flavo r
d efinitio n).

Co mma-sep arated  l is t o f
integ ers.

l ib virt
API
d river

hw_num
a_cp us.
1

Map p ing  o f vCPUs N-M to  NUMA
no d e 1 (d o es no t o verrid e flavo r
d efinitio n).

Co mma-sep arated  l is t o f
integ ers.

l ib virt
API
d river

hw_num
a_mem.
0

Map p ing  N GB o f RAM to  NUMA
no d e 0  (d o es no t o verrid e flavo r
d efinitio n).

Integ er

lib virt
API
d river

hw_num
a_mem.
1

Map p ing  N GB o f RAM to  NUMA
no d e 1 (d o es no t o verrid e flavo r
d efinitio n).

Integ er

Specific
t o

Key Descript ion Support ed values
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l ib virt
API
d river

hw_rng _
mo d el

Ad d s a rand o m-numb er
g enerato r d evice to  the imag e's
instances. The c lo ud
ad ministrato r can enab le and
co ntro l d evice b ehavio r b y
co nfig uring  the instance's flavo r.
By d efault:

The g enerato r d evice is
d isab led .

/dev/random is  used  as the
d efault entro p y so urce. To
sp ecify a p hysical HW RNG
d evice, use the fo llo wing
o p tio n in the nova.conf fi le:

virtio , o r o ther sup p o rted
d evice.

l ib virt
API
d river

hw_scsi
_mo d el

Enab les the use o f VirtIO  SCSI
(virtio -scsi) to  p ro vid e b lo ck
d evice access fo r co mp ute
instances; b y d efault, instances
use VirtIO  Blo ck (virtio -b lk).
VirtIO  SCSI is  a p ara-virtualized
SCSI co ntro ller d evice that
p ro vid es imp ro ved  scalab il i ty
and  p erfo rmance, and  sup p o rts
ad vanced  SCSI hard ware.

virtio-scsi

l ib virt
API
d river

hw_vid e
o _mo d e
l

The vid eo  imag e d river used . vga, cirrus, vmvga, xen, o r 
qxl

l ib virt
API
d river

hw_vid e
o _ram

Maximum RAM fo r the vid eo
imag e. Used  o nly if a 
hw_video:ram_max_mb value
has b een set in the flavo r's  
extra_specs and  that value is
hig her than the value set in 
hw_video_ram.

Integ er in MB (fo r examp le, '6 4' )

Specific
t o

Key Descript ion Support ed values
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l ib virt
API
d river

hw_watc
hd o g _a
ctio n

Enab les a virtual hard ware
watchd o g  d evice that carries o ut
the sp ecified  actio n if the server
hang s. The watchd o g  uses the
i6 30 0 esb  d evice (emulating  a
PCI Intel 6 30 0 ESB). If 
hw_watchdog_action is  no t
sp ecified , the watchd o g  is
d isab led .

disabled -The d evice is  no t
attached . Allo ws the user to
d isab le the watchd o g  fo r the
imag e, even if i t has b een
enab led  using  the imag e's
flavo r. The d efault value fo r
this  p arameter is  disabled .

reset-Fo rcefully reset the
g uest.

poweroff-Fo rcefully p o wer
o ff the g uest.

pause-Pause the g uest.

none-Only enab le the
watchd o g ; d o  no thing  if the
server hang s.

l ib virt
API
d river

o s_co m
mand _li
ne

The kernel co mmand  line to  b e
used  b y the l ib virt d river, instead
o f the d efault. Fo r Linux
Co ntainers (LXC), the value is
used  as arg uments fo r
initial izatio n. This key is  valid
o nly fo r Amazo n kernel, ramd isk,
o r machine imag es (aki, ari, o r
ami).

l ib virt
API
d river
and
VMware
API
d river

hw_vif_
mo d el

Sp ecifies the mo d el o f virtual
netwo rk interface d evice to  use. The valid  o p tio ns d ep end  o n the

co nfig ured  hyp erviso r.

KVM and  QEMU: e1000 , 
ne2k_pci , pcnet, 
rtl8139 , and  virtio .

VMware: e1000 , e1000e, 
VirtualE1000 , 
VirtualE1000e, 
VirtualPCNet32, 
VirtualSriovEthernetCa
rd , and  VirtualVmxnet.

Xen: e1000 , netfront, 
ne2k_pci , pcnet, and  
rtl8139 .

Specific
t o
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VMware
API
d river

vmware_
ad ap tert
yp e

The virtual SCSI o r IDE co ntro ller
used  b y the hyp erviso r.

lsiLogic, busLogic, o r 
ide

VMware
API
d river

vmware_
o styp e

A VMware GuestID which
d escrib es the o p erating  system
installed  in the imag e. This value
is p assed  to  the hyp erviso r when
creating  a virtual machine. If no t
sp ecified , the key d efaults  to  
otherGuest.

See thinkvirt.co m.

VMware
API
d river

vmware_
imag e_v
ers io n

Currently unused . 1

XenAPI
d river

auto _d i
sk_co nfi
g

If true, the ro o t p artitio n o n the
d isk is  auto matically res ized
b efo re the instance b o o ts. This
value is  o nly taken into  acco unt
b y the Co mp ute service when
using  a Xen-b ased  hyp erviso r
with the XenAPI d river. The
Co mp ute service wil l o nly attemp t
to  res ize if there is  a s ing le
p artitio n o n the imag e, and  o nly if
the p artitio n is  in ext3 o r ext4
fo rmat.

true | false

XenAPI
d river

o s_typ e The o p erating  system installed
o n the imag e. The XenAPI d river
co ntains lo g ic that takes d ifferent
actio ns d ep end ing  o n the value
o f the os_type p arameter o f the
imag e. Fo r examp le, fo r 
os_type=windows imag es, it
creates a FAT32-b ased  swap
p artitio n instead  o f a Linux swap
p artitio n, and  it l imits  the injected
ho st name to  less than 16
characters.

linux o r windows

Specific
t o

Key Descript ion Support ed values
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